【问题标题】:Unable to initialize helm (tiller) on newly created GKE cluster无法在新创建的 GKE 集群上初始化 helm(tiller)
【发布时间】:2020-03-17 16:18:23
【问题描述】:

我刚刚在 Google Cloud 平台上创建了一个 GKE 集群。我已经安装在云控制台helm:

$ helm version
version.BuildInfo{Version:"v3.0.0", GitCommit:"e29ce2a54e96cd02ccfce88bee4f58bb6e2a28b6", GitTreeState:"clean", GoVersion:"go1.13.4"}

我还创建了必要的serviceaccount 和clusterrolebinding 对象:

$ cat helm-rbac.yaml
apiVersion: v1
kind: ServiceAccount
metadata:
  name: tiller
  namespace: kube-system
---
apiVersion: rbac.authorization.k8s.io/v1
kind: ClusterRoleBinding
metadata:
  name: tiller
roleRef:
  apiGroup: rbac.authorization.k8s.io
  kind: ClusterRole
  name: cluster-admin
subjects:
  - kind: ServiceAccount
    name: tiller
    namespace: kube-system


$ kubectl apply -f helm-rbac.yaml                                                                    

serviceaccount/tiller created
clusterrolebinding.rbac.authorization.k8s.io/tiller created

但是尝试初始化 tiller 时出现以下错误:

$ helm init --service-account tiller --history-max 300
Error: unknown flag: --service-account

这是为什么呢?

【问题讨论】:

    标签: kubernetes google-cloud-platform google-kubernetes-engine kubernetes-helm


    【解决方案1】:

    但是尝试初始化分蘖会给我以下错误:

    错误:未知标志:--service-account

    这是为什么呢?

    Helm 3 is a major upgrade。 Tiller 组件现已过时。

    没有命令 helm init 因此也删除了标志 --service-account。

    Helm 3 的内部实现与 Helm 2 相比发生了很大变化。最明显的变化是删除了 Tiller。

    【讨论】:

      猜你喜欢
      • 2019-12-12
      • 1970-01-01
      • 2018-09-21
      • 1970-01-01
      • 2017-02-16
      • 2020-12-07
      • 1970-01-01
      • 2021-09-30
      • 1970-01-01
      相关资源
      最近更新 更多