【问题标题】:certificate signed by unknown authority Kubernetes Engine由未知权威 Kubernetes Engine 签署的证书
【发布时间】:2019-03-01 14:32:30
【问题描述】:

当我将 docker 映像部署到 Kubernetes Engine 时,

pod 无法初始化,pod 只是向https://jsonplaceholder.typicode.com/ 发出简单的获取请求

我收到一条错误消息certificate signed by unknown authority

【问题讨论】:

  • 如何创建容器镜像?您是否使用空的 Docker 映像(例如 scratch 或类似的),因此不存在根证书包?
  • FROM alpine COPY backend /backend CMD ["/backend"] RUN chmod 755 /backend
  • command CMD ["/backend"] RUN chmod 755 /backend 是因为我有另一个问题stackoverflow.com/questions/52488927/…
  • 您是否再次构建了后端 Windows?您用来构建二进制文件的命令是什么?
  • @CosmicOssifrage 我的错,实际上我确实做到了:"set GOOS=linux" 我只是在这里输入错误,我会尝试那个解决方案

标签: go kubernetes google-cloud-platform containers google-kubernetes-engine


【解决方案1】:

从您问题中的 cmets 来看,我希望您遇到的常见问题是 Alpine 基础映像未填充 ca-certificates 包,该包包含许多根 CA 证书来锚定您的信任根。

将以下命令添加到您的Dockerfile 以确保将它们安装在生成的映像中:

RUN apk update && apk add ca-certificates && rm -rf /var/cache/apk/*

(我们在单个RUN 步骤中运行多个操作,直至最终图像层中的avoid introducing unnecessary bloat)。

容器注册表中也提供了包含 CA 证书包的基础镜像(尽管在此声明中,我没有声明它们的适用性或出处)。

【讨论】:

  • 谢谢你彻底解决了,非常感谢:D
猜你喜欢
  • 2016-08-24
  • 1970-01-01
  • 2018-04-22
  • 2021-02-08
  • 1970-01-01
  • 2019-09-01
  • 1970-01-01
  • 2021-01-29
  • 2019-11-16
相关资源
最近更新 更多