【问题标题】:Initial job has not accepted any resources in AWS EMR初始作业未接受 AWS EMR 中的任何资源
【发布时间】:2020-02-01 03:17:09
【问题描述】:

我在 AWS 中有一个 EMR 集群。

我正在构建一个 RStudio 服务器来使用该集群。

我能够得到一个 spark-shell 并执行 spark.sql("show tables").show 并从运行 RStudio 的服务器查看 HDFS 中的表。

但是,如果我执行 spark.sql("select * from ny_taxi_hdfs limit 10").show 它会失败并出现错误。 初始作业未接受任何资源。

如果我从主人那里做同样的事情,它就可以正常工作。

它看起来确实在使用纱线“(master = yarn,app id = application_1568817071939_0034)”

甚至不知道在哪里看。

【问题讨论】:

    标签: apache-spark


    【解决方案1】:

    防火墙/安全组。一旦我打开它,一切正常。 我讨厌我提出一个问题,然后在一天后回答它。

    【讨论】:

      猜你喜欢
      • 2017-11-18
      • 1970-01-01
      • 1970-01-01
      • 2015-06-10
      • 1970-01-01
      • 1970-01-01
      • 2016-12-11
      • 1970-01-01
      相关资源
      最近更新 更多