【问题标题】:SQL server 2008 backup error - Operating system error 5(failed to retrieve text for this error. Reason: 15105) [closed]SQL Server 2008 备份错误 - 操作系统错误 5(无法检索此错误的文本。原因:15105)[关闭]
【发布时间】:2011-01-24 19:09:31
【问题描述】:

谁能帮助我,我正在尝试备份位于 localhost\SQLEXPRESS 上的数据库,但我不断收到以下错误:

Backup failed for Server 'localhost\SqlExpress'.  (Microsoft.SqlServer.SmoExtended)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=10.0.2531.0+((Katmai_PCU_Main).090329-1045+)&EvtSrc=Microsoft.SqlServer.Management.Smo.ExceptionTemplates.FailedOperationExceptionText&EvtID=Backup+Server&LinkId=20476


ADDITIONAL INFORMATION:

System.Data.SqlClient.SqlError: Cannot open backup device 'C:\backup.bak'. Operating system error 5(failed to retrieve text for this error. Reason: 15105). (Microsoft.SqlServer.Smo)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=10.0.2531.0+((Katmai_PCU_Main).090329-1045+)&LinkId=20476

谁能解释我在这里做错了什么??

谢谢

【问题讨论】:

  • 在 Windows 7/2008 上,不允许将文件保存到 C 的根目录,因此,如果您正在运行这两个操作系统之一,那么这是有道理的。
  • 也许题外话,但对我有用!
  • 我遇到了这个问题,它是由已经存在的文件引起的。我需要添加代码来处理它 - 并且可能在 Backup 对象中寻找一个选项(我正在使用 c# 在我的应用程序中运行备份)
  • 彼得之前的评论对我有用。从 C:\Users\ 读取备份文件导致错误,而将其移动到另一个驱动器解决了问题。

标签: sql-server backup


【解决方案1】:

SQL Server 似乎没有访问文件 C:\backup.bak 的权限。我会检查分配给 SQL Server 服务帐户的帐户的权限。

作为解决方案的一部分,您可能希望将备份文件保存到 C: 驱动器根目录以外的其他位置。这可能是您遇到权限问题的原因之一。

【讨论】:

    【解决方案2】:

    当没有足够的可用空间来创建备份时,我遇到了这个错误。

    【讨论】:

    • 我遇到了完全相同的问题。关于没有足够磁盘空间的简单而简单的错误消息会很有帮助。谢谢微软
    • 我也遇到了这个错误,通过扩展服务器磁盘空间解决了。
    • 是的,在阅读了这个答案后,我检查了我的驱动器,结果震惊了,只剩下区区 300MB 的空间:D 删除旧的过时备份释放了足够的空间。
    • 节省我的时间!谢谢
    • 不客气。多年过去了,但我们仍然看到这条“有用的信息”。
    【解决方案3】:

    假设 *.bak 文件与 SQL Express 实例位于同一台机器上,这可能是权限问题。

    如果您下载 procmon http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx,您可以过滤该文件路径,查找 ACCESS_DENIED 错误,如果有任何错误,您可以看到无法访问的帐户名称。

    【讨论】:

    • 我遇到了一个完全不同的问题(磁盘空间不足),它显示在相同的错误号下 - procmon 为我指明了正确的方向 - 绝对是未来要记住的问题。谢谢马丁。
    • @Martin:有没有可能知道如何使用 ProcMon 找出错误消息?
    【解决方案4】:

    我也遇到了这个错误。

    问题只是我必须手动为 MDF 和 LDF 文件的文件位置创建完整的目录结构。

    因为没有正确报告丢失的目录,SQL-Server 感到羞耻!

    【讨论】:

      【解决方案5】:

      我遇到了同样的错误。我一直在尝试通过为运行 SQL 客户端服务的帐户设置更高的权限来解决此问题,但它没有帮助。问题是我只在我的帐户中运行 MS Sql Management Studio。所以,下次……如果使用启用了 UAC 的 Win7,请确保您以 以管理员身份运行 身份运行它。

      【讨论】:

        【解决方案6】:

        是的,这是安全问题。检查启动 SQL Server 2008 的文件夹权限和服务帐户。

        【讨论】:

          【解决方案7】:

          我遇到了这个错误。在我打开“MSSQL10_50”日志文件夹中的 SQLServer 日志文件之前,没有什么对我有用。这清楚地说明了哪个文件不能被覆盖。原来.mdf 文件被写入“MSSQL10”数据文件夹。我确保该文件夹具有与“MSSQL10_50”等效文件夹相同的 SQLServer 用户权限。然后一切都奏效了。

          这里的问题是错误详细信息被记录但没有报告,所以检查日志。

          【讨论】:

            猜你喜欢
            • 1970-01-01
            • 2012-04-27
            • 2011-04-26
            • 1970-01-01
            • 1970-01-01
            • 1970-01-01
            • 1970-01-01
            • 2010-09-12
            • 1970-01-01
            相关资源
            最近更新 更多