【发布时间】:2019-07-18 12:04:29
【问题描述】:
在尝试访问 mongodb 时出现连接失败的错误
-
在运行
mongod命令时,我得到了2019-02-25T11:05:05.870+0530 I CONTROL [initandlisten] MongoDB starting : pid=2580 port=27017 dbpath=/data/db 64-bit host=gten 2019-02-25T11:05:05.870+0530 I CONTROL [initandlisten] db version v3.6.3 2019-02-25T11:05:05.870+0530 I CONTROL [initandlisten] git version: 9586e557d54ef70f9ca4b43c26892cd55257e1a5 2019-02-25T11:05:05.870+0530 I CONTROL [initandlisten] OpenSSL version: OpenSSL 1.1.0g 2 Nov 2017 2019-02-25T11:05:05.870+0530 I CONTROL [initandlisten] allocator: tcmalloc 2019-02-25T11:05:05.870+0530 I CONTROL [initandlisten] modules: none 2019-02-25T11:05:05.870+0530 I CONTROL [initandlisten] build environment: 2019-02-25T11:05:05.871+0530 I CONTROL [initandlisten] distarch: x86_64 2019-02-25T11:05:05.871+0530 I CONTROL [initandlisten] target_arch: x86_64 2019-02-25T11:05:05.871+0530 I CONTROL [initandlisten] options: {} 2019-02-25T11:05:05.962+0530 I STORAGE [initandlisten] exception in initAndListen: IllegalOperation: Attempted to create a lock file on a read-only directory: /data/db, terminating 2019-02-25T11:05:05.962+0530 I CONTROL [initandlisten] now exiting 2019-02-25T11:05:05.962+0530 I CONTROL [initandlisten] shutting down with code:100
当我运行mongo 命令时,我得到了
MongoDB shell version v4.0.6
connecting to: mongodb://127.0.0.1:27017/?gssapiServiceName=mongodb
2019-02-25T11:16:44.802+0530 E QUERY [js] Error: couldn't connect to server 127.0.0.1:27017, connection attempt failed: SocketException: Error connecting to 127.0.0.1:27017 :: caused by :: Connection refused :
connect@src/mongo/shell/mongo.js:343:13
@(connect):1:6
exception: connect failed
我不知道 [https://docs.mongodb.com/manual/tutorial/install-mongodb-on-ubuntu/] 和 [https://www.howtoforge.com/tutorial/install-mongodb-on-ubuntu-16.04/]] 有什么问题 安装 mongo。
配置: 我正在使用 UBUNTU 18.04。 感谢您提供任何帮助,我已经通过了很多答案并尝试了所有但仍然面临同样的问题。在此先感谢
在做了很多事情之后,我得到了
2019-02-25T18:52:27.197+0530 I CONTROL [main] Automatically disabling TLS 1.0, to force-enable TLS 1.0 specify --sslDisabledProtocols 'none'
2019-02-25T18:52:27.200+0530 I CONTROL [initandlisten] MongoDB starting : pid=27390 port=27017 dbpath=/data/db 64-bit host=gten
2019-02-25T18:52:27.200+0530 I CONTROL [initandlisten] db version v4.0.6
2019-02-25T18:52:27.200+0530 I CONTROL [initandlisten] git version: caa42a1f75a56c7643d0b68d3880444375ec42e3
2019-02-25T18:52:27.200+0530 I CONTROL [initandlisten] OpenSSL version: OpenSSL 1.1.0g 2 Nov 2017
2019-02-25T18:52:27.200+0530 I CONTROL [initandlisten] allocator: tcmalloc
2019-02-25T18:52:27.200+0530 I CONTROL [initandlisten] modules: none
2019-02-25T18:52:27.200+0530 I CONTROL [initandlisten] build environment:
2019-02-25T18:52:27.200+0530 I CONTROL [initandlisten] distmod: ubuntu1804
2019-02-25T18:52:27.200+0530 I CONTROL [initandlisten] distarch: x86_64
2019-02-25T18:52:27.200+0530 I CONTROL [initandlisten] target_arch: x86_64
2019-02-25T18:52:27.200+0530 I CONTROL [initandlisten] options: {}
2019-02-25T18:52:27.200+0530 E STORAGE [initandlisten] Failed to set up listener: SocketException: Address already in use
2019-02-25T18:52:27.200+0530 I CONTROL [initandlisten] now exiting
2019-02-25T18:52:27.200+0530 I CONTROL [initandlisten] shutting down with code:48
【问题讨论】:
-
看来您可能没有 data/db 文件夹的权限。您可能希望获得运行 mongo 的帐户的所有权。
-
我认为你没有权限。请更新权限
-
我已授予权限但仍无法运行
-
设置权限后出现什么错误?向我们展示这些日志
标签: database mongodb installation