【问题标题】:Unable to run in production mode on heroku server无法在 Heroku 服务器上以生产模式运行
【发布时间】:2019-02-04 02:41:41
【问题描述】:

我有一个部署在 heroku 上的应用程序,出于某些原因,我想在那里启用 Web 控制台。 这是设置详细信息: 在 Gemfile 中

ruby '2.3.0'

rails 4.2

web console 3.3.0

在 Application.rb 中

config.web_console.development_only = false
 config.web_console.whitelisted_ips = [MY IP ADDRESS]

当我尝试使用生产环境在本地运行时,即使我添加其他机器 IP 地址(通过 LAN 连接)并尝试访问安装在我机器上的 Web 应用程序,它也能正常工作(当我删除他们的 IP 时)地址然后它没有在网页上显示任何控制台)所以我可以说 config.web_console.whiltelisted_ips 配置正在工作。

但是当我在白名单中添加我的外部 IP 地址(公共 IP 地址)并推送到 heroku 时,我无法在那里看到 Web 控制台。

总是在控制台中看到一些随机 ip,如下所示:

Cannot render console from 10.63.146.94! Allowed networks: 103.15.67.226, 174.129.192.200, 127.0.0.0/127.255.255.255, ::1

还有这个“10.63.146.94!”永远改变。

我不确定我在哪里遗漏了什么或者 gem 中有一些错误?

【问题讨论】:

    标签: ruby ruby-on-rails-4 rubygems


    【解决方案1】:

    10.* 的 IP 范围是私有的,这意味着运行 Web 控制台的代码将另一台 Heroku 机器视为源。如果代码没有考虑像 X-Forwarded-For 这样的标头,通常会发生这种情况。

    您可能会发现使用 heroku 提供的 Web 控制台更容易。

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 2014-05-11
      • 1970-01-01
      • 2014-03-09
      • 2022-08-19
      • 2017-12-07
      • 2021-02-06
      • 1970-01-01
      • 2020-03-03
      相关资源
      最近更新 更多