【发布时间】:2015-04-15 10:39:31
【问题描述】:
我有一个现有的 mnesia 数据库,现在我开始使用适当的 erlang 版本。我用 relx。
但是,问题是我需要与现有的 mnesia 数据库兼容,并且在创建时,节点名称是 nonode@nohost。我已经看到,对于 mnesia,节点名称不仅仅是目录名称的一部分,即如果不使用备份和恢复以及一些处理,它就无法更改。
我可以使用
运行发布bin/XXXX 控制台-name nonode@nohost
并找到数据库。但是,我想使用
bin/XXXX start -name nonode@nohost
但随后 -name 将被忽略。当我附加并执行 node() 时,我得到了其他东西。
我也找到了 vm.args 文件并将节点名称更改为 nonode@nohost 那里,但是得到了
{error_logger,{{2015,2,14},{13,25,17}},"无效节点名称:~p~n",['nonode@nohost']}
所以似乎有人真的确定名字不能是 nonode@nohost :-) 我这样做的唯一选择是:How to rename the Node running a mnesia Database
【问题讨论】: