【问题标题】:RabbitMQ won't start after power failureRabbitMQ 断电后无法启动
【发布时间】:2012-05-18 18:47:06
【问题描述】:

我正在我的机器上运行一个 RabbitMQ 服务器实例。但在大楼停电后,我无法让兔子启动。

没有其他服务在同一个 TCP 端口上运行,我尝试重新安装 rabbit 和 erlang,但似乎没有任何效果。

我在跑步:

  • CentOS 5.4 版(最终版)
  • 兔rabbitmq-server-2.8.2-1.noarch
  • erlang-R14B-03.3.el5.x86_64

startup_error 日志为空,但 startup_log 包含:

{
error_logger,
{
    {2012,5,10},
    {9,35,43}
},
"Protocol: ~p: register error: ~p~n",
[
    "inet_tcp",
    {
        {
            badmatch,
            {
                error,
                econnrefused
            }
        },
        [
            {
                inet_tcp_dist,
                listen,
                1
            },
            {
                net_kernel,
                start_protos,
                4
            },
            {
                net_kernel,
                start_protos,
                3
            },
            {
                net_kernel,
                init_node,
                2
            },
            {
                net_kernel,
                init,
                1
            },
            {
                gen_server,
                init_it,
                6
            },
            {
                proc_lib,
                init_p_do_apply,
                3
            }
        ]
    }
]
}{
error_logger,
{
    {2012,5,10},
    {9,35,43}
},
crash_report,
[
    [
        {
            initial_call,
            {
                net_kernel,
                init,
                [
                    'Argument__1'
                ]
            }
        },
        {
            pid,
            <0.20.0>
        },
        {
            registered_name,
            [

            ]
        },
        {
            error_info,
            {
                exit,
                {
                    error,
                    badarg
                },
                [
                    {
                        gen_server,
                        init_it,
                        6
                    },
                    {
                        proc_lib,
                        init_p_do_apply,
                        3
                    }
                ]
            }
        },
        {
            ancestors,
            [
                net_sup,
                kernel_sup,
                <0.9.0>
            ]
        },
        {
            messages,
            [

            ]
        },
        {
            links,
            [
                #Port<0.90>,
                <0.17.0>
            ]
        },
        {
            dictionary,
            [
                {
                    longnames,
                    false
                }
            ]
        },
        {
            trap_exit,
            true
        },
        {
            status,
            running
        },
        {
            heap_size,
            610
        },
        {
            stack_size,
            24
        },
        {
            reductions,
            509
        }
    ],
    [

    ]
]
}{
error_logger,
{
    {2012,5,10},
    {9,35,43}
},
supervisor_report,
[
    {
        supervisor,
        {
            local,
            net_sup
        }
    },
    {
        errorContext,
        start_error
    },
    {
        reason,
        {
            'EXIT',
            nodistribution
        }
    },
    {
        offender,
        [
            {
                pid,
                undefined
            },
            {
                name,
                net_kernel
            },
            {
                mfargs,
                {
                    net_kernel,
                    start_link,
                    [
                        [
                            rabbitmqprelaunch4868,
                            shortnames
                        ]
                    ]
                }
            },
            {
                restart_type,
                permanent
            },
            {
                shutdown,
                2000
            },
            {
                child_type,
                worker
            }
        ]
    }
]
}{
error_logger,
{
    {
        2012,
        5,
        10
    },
    {
        9,
        35,
        43
    }
},
supervisor_report,
[
    {
        supervisor,
        {
            local,
            kernel_sup
        }
    },
    {
        errorContext,
        start_error
    },
    {
        reason,
        shutdown
    },
    {
        offender,
        [
            {
                pid,
                undefined
            },
            {
                name,
                net_sup
            },
            {
                mfargs,
                {
                    erl_distribution,
                    start_link,
                    [

                    ]
                }
            },
            {
                restart_type,
                permanent
            },
            {
                shutdown,
                infinity
            },
            {
                child_type,
                supervisor
            }
        ]
    }
]
}{
error_logger,
{
    {
        2012,
        5,
        10
    },
    {
        9,
        35,
        43
    }
},
std_info,
[
    {
        application,
        kernel
    },
    {
        exited,
        {
            shutdown,
            {
                kernel,
                start,
                [
                    normal,
                    [

                    ]
                ]
            }
        }
    },
    {
        type,
        permanent
    }
]
}{
"Kernel pid terminated",
application_controller,
"{application_start_failure,kernel,{shutdown,{kernel,start,[normal,[]]}}}"
}

有人有想法吗?

【问题讨论】:

  • 您是否检查过它的一部分是否已经在运行。尝试 ps 看看是否启动了阻止它完全启动的东西。
  • 检查 epmd 是否正在运行,如果是,则杀死它
  • 我完全忘记了这个问题。是的,问题是某些东西使用了相同的端口。解决后我又收到了一次错误,如果我没记错的话,那是仍在运行的 epmd。正如@bighostkim 评论的那样。

标签: crash erlang centos rabbitmq


【解决方案1】:

econnrefused 在开头清楚地表明有东西在同一个端口上监听,netstat -plten 可以显示它是什么。

【讨论】:

  • 我完全忘记了这个问题。是的,问题是某些东西使用了相同的端口。解决后我又收到了一次错误,如果我没记错的话,那是仍在运行的 epmd。正如@bighostkim 评论的那样。
猜你喜欢
  • 2016-03-04
  • 1970-01-01
  • 2020-07-03
  • 2013-11-15
  • 2012-02-17
  • 1970-01-01
  • 2013-01-27
  • 2019-01-18
  • 1970-01-01
相关资源
最近更新 更多