【问题标题】:Kubernetes deployment with Docker image使用 Docker 映像部署 Kubernetes
【发布时间】:2018-08-24 17:01:07
【问题描述】:

我在本地 Mac 上运行 Kubernetes (Minikube)。

我正在尝试使用 Docker 映像设置部署并收到以下错误。但是,使用 Docker 映像“gcr.io/google-samples/node-hello:1.0”的 hello-world 部署按预期工作。

我可以从本地机器上的控制台中提取图像。我在这里缺少任何设置吗?

"拉取图片失败 “docker.XYZ.com/dpace/dev/docker-service”:RPC 错误: 代码 = 未知 desc = 来自守护程序的错误响应:获取 https://docker.XYZ.com/v2/:拨号tcp:查找 10.0.2.3:53 上的 docker.XYZ.com:读取 udp 10.0.2.15:59292->10.0.2.3:53: i/o 超时"

我可以在本地机器上使用docker pull docker.XYZ.com/dpace/dev/docker-service 提取图像,而不会出现任何身份验证问题。拉取图片不需要授权。

我尝试登录 Minikube VM 并且 Docker 映像返回以下内容。

$ docker images 存储库标签
图像 ID 创建大小 k8s.gcr.io/kubernetes-dashboard-amd64 v1.8.1
e94d2f21bc0c 3 个月前 121MB gcr.io/google-containers/kube-addon-manager v6.5
d166ffa9201a 4 个月前 79.5MB gcr.io/k8s-minikube/storage-provisioner v1.8.0
4689081edb10 4 个月前 80.8MB gcr.io/k8s-minikube/storage-provisioner v1.8.1
4689081edb10 4 个月前 80.8MB k8s.gcr.io/k8s-dns-sidecar-amd64 1.14.5
fed89e8b4248 5 个月前 41.8MB k8s.gcr.io/k8s-dns-kube-dns-amd64 1.14.5
512cd7425a73 5 个月前 49.4MB k8s.gcr.io/k8s-dns-dnsmasq-nanny-amd64 1.14.5
459944ce8cc4 5 个月前 41.4MB k8s.gcr.io/echoserver
1.4 a90209bb39e3 21 个月前 140MB gcr.io/google_containers/pause-amd64 3.0
99e59f495ffa 22 个月前 747kB k8s.gcr.io/pause-amd64
3.0 99e59f495ffa 22 个月前 747kB gcr.io/google-samples/node-hello 1.0
4c7ea8709739 23 个月前 644MB

虽然图像在那里,但当我尝试提取现有图像时,它会失败并出现以下错误。

$ docker pull gcr.io/google-samples/node-hello:1.0 来自的错误响应 守护进程:获取https://gcr.io/v2/:拨打tcp:查找gcr.io on 10.0.2.3:53: 读取 udp 10.0.2.15:44023->10.0.2.3:53: i/o 超时

当我尝试“docker login docker.XYZ.com”时,它会提示我输入凭据。输入密码后会抛出以下错误。尝试拉取图像时也出现同样的错误。

"来自守护进程的错误响应:获取https://docker.XYZ.com/v2/:拨打tcp: 在 10.0.2.3:53 上查找 docker.XYZ.com:读取 udp 10.0.2.15:41849->10.0.2.3:53: i/o 超时"

“curl google.com”命令也不起作用。 “无法解决 主机:google.com”

在 Minikube VM 中进行的任何设置。我使用 VirtualBox。

【问题讨论】:

  • this question 有帮助吗?
  • 您可能缺少提取该映像所需的身份验证/docker 登录凭据。仔细检查您尝试使用的图像是否是公开的。然后检查您尝试访问的注册表是否可以从 minkube 虚拟机内部访问。

标签: docker kubernetes minikube


【解决方案1】:

您的 minikube 中的 DNS 似乎已损坏,这就是您无法提取任何内容的原因。

这里有一个Issue on Github 有类似的问题。

尝试将您的 minikube 和虚拟机管理程序(在大多数情况下是 Virtualbox)更新到最新版本(检查 here)并重新创建集群,这应该会有所帮助。

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 2015-04-16
    • 1970-01-01
    • 2019-12-16
    • 2020-08-01
    • 2019-01-08
    • 1970-01-01
    • 2019-02-28
    相关资源
    最近更新 更多