【发布时间】:2017-05-15 02:54:32
【问题描述】:
我刚刚开始使用 Oracle 数据导出和导入,并且第一次一切正常。但是第二天我又回来了,在相同的系统上重复了完全相同的步骤,但得到 ORA-01435: user does not exist 错误。
所有机器的系统规格:
-操作系统:Windows 2012 R2 x64
-Oracle 服务器:Oracle 11G Express x64
目标: 我正在从 Oracle 服务器 1 导出数据并导入到 Oracle 服务器 2。
程序: 从 Oracle 服务器 1 导出数据转储成功。
但在 Oracle 服务器 2 上导入数据转储时,我遵循以下过程:
-停止 IIS 服务
net stop WAS
在导入前创建架构/用户帐户并授予权限
net stop WAS
sqlplus / as sysdba;
CREATE user PIE1 identified by PASS1;
GRANT ALL PRIVILEGES TO PIE1;
GRANT IMP_FULL_DATABASE TO PIE1;
根据 oracle 的说法,一切顺利,但请看下面的第一张图片。在 DBeaver 中,我可以看到只创建了用户帐户 PIE1,但没有架构。 Oracle issue 1. User account created, but not the Schema
问题 1: 根据 Oracle 的说法,“创建用户”命令应该也创建一个关联的模式。任何人都知道为什么这不再为我工作?它在前一天晚上工作过一次。
然后我继续导入过程如下:
imp PIE1/PASS1@xe file=c:\Backups\AVUSER2_6_7.dmp log=c:\Backups\import.log fromuser=AVUSER2_6_7 touser=PIE1;
但是得到以下错误: Oracle claims the User doesn't exist even though it does
Oracle 声称用户不存在,即使它存在。我重复了整个过程,甚至创建了相同的导入/导出用户帐户和凭据,但仍然出现此错误。
问题 2:知道为什么 Oracle “找不到”数据库中明确存在的用户帐户吗?
附加信息:
检查我的 windows 帐户是否在管理员组中
检查了我的 windows 帐户是否在 ORA_DBA 组中
以管理员身份打开所有 CMD 提示符
【问题讨论】:
-
是否有可能在 DBeaver 中刷新了 Users 文件夹但未刷新 Schemas 文件夹?也许导入错误是因为
FROMUSER而不是TOUSER;你确定转储文件包含用户 AVUSER2_6_7? -
嗨 Jon,我已经用相同的结果刷新了整个树。我还注意到,即使在手动创建架构之后。运行导入后,架构被删除。
-
您是否真的使用导出数据泵和常规导入,或者这是一个错字?我不认为这两者会兼容。能否包含您使用的完整导出命令?
-
问题是“导出数据转储”,而不是“泵”-我起初也误读了 *8-) 顺便说一句,虽然我可以理解您想在屏幕截图中显示 DBeaver GUI 差异, 最好包含命令行会话的文本而不是那些图像 - 更容易阅读,它们可以搜索,有些人根本无法访问图像。