【问题标题】:Laravel log files could not be opend, permission deniedLaravel 日志文件无法打开,权限被拒绝
【发布时间】:2018-07-08 21:38:55
【问题描述】:

我在 ubuntu 服务器上运行 laravel 应用程序。每小时有许多 cron 作业在运行。 问题是,有时应用程序会抛出一个错误,即由于权限被拒绝而无法打开日志文件。如果我更新目录权限,它可以解决问题。但是无法连续检查和解决问题。

自动更改目录权限的原因是什么,我该如何解决?

【问题讨论】:

    标签: laravel file-permissions ubuntu-server


    【解决方案1】:

    给予递归权限

    sudo chmod 775 -R storage/logs
    

    【讨论】:

    • 你永远不应该给 777 权限
    【解决方案2】:

    如果你是 ubuntu 用户 运行这个

    sudo chown -R USER:www-data storage
    

    非常适合 nginx。将存储组所有权和 bootstrap/cache 目录更改为 www-data

    sudo chgrp -R www-data storage bootstrap/cache
    sudo chmod -R ug+rwx storage bootstrap/cache
    

    【讨论】:

      【解决方案3】:

      您很可能使用的是 Ubuntu,在这种情况下,您当前的用户可能没有写入权限。 使用此命令重新授予自己对整个存储文件夹的读写权限。

      sudo chown -R $USER storage

      【讨论】:

        猜你喜欢
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 2020-05-31
        • 2021-05-11
        • 2013-06-05
        • 2015-07-30
        • 2018-09-14
        相关资源
        最近更新 更多