【发布时间】:2011-02-28 16:20:16
【问题描述】:
当我尝试通过本地服务器发送时收到此错误
CDO.Message.1 error '80070005'
Access is denied.
/mail.asp, line xxx
这是我正在使用的代码
MailBodyText = "TEST"
Set objNewMail = CreateObject("CDO.Message")
objNewMail.To = sSendTo
objNewMail.From = "webmaster@EXAMPLE.com"
objNewMail.Cc = "webmaster@EXAMPLE.com"
objNewMail.Subject = "Information Request & Feedback"
objNewMail.HTMLBody = "The following information was sent from " & sEmail & ":" & "<br>" & CHR(13) & MailBodyText & "<br>copies of this mail we sent to :"& sSendTo
objNewMail.Send
Set objNewMail = Nothing
似乎是 ISSUR 的权限错误,没有写入 mailroot/pickup 文件夹的写入权限。
但我们已经检查过,并且该站点使用的服务帐户似乎拥有权限。
问题是这个错误总是文件权限错误吗?
问题如何知道/设置 CDO 正在使用的位置?这样我们就可以确认权限了
还有什么办法可以解决这个问题?
【问题讨论】:
标签: iis-7 asp-classic cdo.message