【发布时间】:2011-12-12 20:17:07
【问题描述】:
我的基于 RefineryCMS 1.0.8 的应用程序出现问题 部署在heroku上。
Heroku 的请求超时为 30 秒。上传文件时 > 4MO 通过 RefineryCMS admin,有时需要超过 30 秒来执行请求(主要是因为需要时间 将文件上传到 s3)。
在这种情况下,测功机将被“冻结”并且 大约 30 分钟无响应(在此期间的每个请求都结束 H12 错误请求超时)。这种行为正是this discussion 中最后一条消息中描述的 christos
从此other discussion 和the heroku documentation :“直接上传到 S3 是首选方法,如果您是 处理大于 4MB 的文件上传。这个想法是跳过跳跃 到您的测功机,直接从最终用户浏览器建立连接 到 S3。”
直接上传到 S3 应该是解决方案,但看起来很难 让我用 RefineryCMS / Dragonfly / Fog 正确实施它。我不确定是否可以不对这些工具进行大的修改,我想知道是否有替代方案。
感谢您的帮助
【问题讨论】:
标签: ruby-on-rails heroku amazon-s3 refinerycms fog