【问题标题】:HTTP/1.1 500 Server Error With ASP classicHTTP/1.1 500 服务器错误与 ASP 经典
【发布时间】:2013-02-09 02:16:25
【问题描述】:

首先,我想声明这是我创建的第一个 ASP 经典页面,自从第一次在 IIS 上部署以来,我创建了服务器 500 错误。我已经搜索了整个网络,并已尽一切可能做到这一点,但都是徒劳的。

我使用 Web Matrix 创建了一个经典的 ASP 页面。这是一个基于 Web 的仪表板,它连接到 MSSQL 服务器并获取必要的信息。我在 php 中有一个类似的应用程序,它运行完美,但我想学习 ASP,因此试图在 ASP 上制作一个类似的网络应用程序。这个应用程序在 Web Matrix 上运行得非常好。当我从网络矩阵(在 chrome 和 IE 上)运行这个应用程序时,它连接到所需的数据库,我可以按预期浏览详细信息。当我在 IIS(我的 Windows 7 电脑上的本地主机)上托管它时,问题就开始了。这是我遵循的确切程序:

  1. 在 IIS 上创建了一个名为“YCube”的新站点
  2. 使用基本设置,我为应用程序提供了以下物理路径 (D:\YVXS\Personal\ASP\SSTool\Ycube) {项目输出文件夹}
  3. 在绑定页面我分配了81端口
  4. IIS 身份验证设置为“匿名身份验证”
  5. asp 的应用程序池设置为经典(正如 IIS 首次声明它无法在集成模式下执行任务)

之后,当我尝试浏览 localhost:81/menu.asp 时,它给了我服务器 500 错误。 21 天研究现在开始(以下要点)

  1. 为了得到网页上的描述性错误,我做了以下操作,但错误描述没有改变 IIS->asp->Compliation->将错误发送到浏览器 =true,IE 上的友好 http 错误 = 禁用

  2. IIS 日志文件,不确定我是否无法理解错误,但我正在关注日志文件 (C:\inetpub\logs\LogFiles\W3SVC1

2013-02-23 08:07:44 ::1 GET /menu.asp |-|ASP_0147|500_Server_Error 80 - ::1

  1. 只有在 IIS 论坛上,我才意识到 global.asa 文件可能会导致这个问题,我删除了这个文件并尝试了,一切都是徒劳的

  2. 我的站点的文件夹和文件权限是只读的,但是我也尝试了相同的读写权限,这也没有帮助

  3. 在 IIS 的错误页面上,我已将“编辑功能设置”更改为“详细错误”,这也没有给我任何进一步的错误描述。

  4. 我卸载 IIS 并重新安装了 24 次,但没有任何反应

  5. 有人建议创建一个虚拟 asp 文件并尝试托管相同的 IIS,所以我使用了一个小代码

<HTML> <BODY> This page was last refreshed on <%= Now() %>. </BODY> </HTML>, 这给出了正确的输出(此页面最后一次刷新是在 18:88:22....),但是对于我原来的 asp 页面,我仍然收到服务器 500 错误

  1. 我的一个朋友建议从 IIS 中删除所有其他托管网页并尝试(我在 IIS 上有一个 PHP),因此我删除了相同的并尝试了,根本没有任何更改

    李>
  2. 事件日志文件未显示任何与 ASP 相关的内容(只有少数文件表明我的 PC 意外关闭)

  3. 我创建了第二个 ASP 文件,它在后台具有 MS 访问权限,这也给了我相同的服务器 500 错误

  4. 我尝试过的其他事情是更改 web.config 文件以发送详细的错误,(我忘记了确切的行)但这也没有帮助我

这是我的系统配置和其他详细信息 Windows 7 专业版、IIS7.5.7600、MSSQLR2express。另请注意,我已尝试将其托管在我拥有的两台其他电脑(Windows 7)和 Office Server 2003 上,但都给了我相同的服务器 500 错误。

从没想过学习一个经典的 asp 会让我融入这一切爵士乐...请帮助..

【问题讨论】:

  • 感谢这个 rene....我之前已经通过它...我能够访问 favicon.ico 你...相反我注意到在 IIS 中的 MIMe 类型我没有查看.asp扩展名(在IIS安装中“关闭Windows功能”中选择了asp..可能是因为这个..我如何添加.asp(我的意思是添加.asp时需要提供的详细信息在 MIME 中)
  • 您的简单 asp 测试页面正在运行,所以这不是问题。也许某些古老的 COM 组件丢失或未注册。您可以尝试support.microsoft.com/kb/311766 甚至ProcessExplorer 来查看文件/注册表项是否无法读取/打开。
  • 此页面可能会告诉您如何获得更多有用的错误消息iis.net/learn/application-frameworks/…

标签: asp-classic iis-7.5


【解决方案1】:

在 IIS 中配置 ASP 站点时需要注意的几件事

1) 启用父路径 = true

2) 如果您有 64 位机器,则需要将您的应用程序池设置为 32 位。

这是我们需要注意的默认设置。

【讨论】:

  • 感谢您的回答,Jinesh!我已经从生产服务器下载了一个非常重要的遗留应用程序到 Windows 10 机器,以便在 localhost 中进行一些审查和重新开发。当 IIS 不提供 .asp 页面时,我感到很困惑,因为我已经进行了十年前的所有配置更改(包括父路径)。将应用程序池默认值更改为“启用 32 位应用程序”即可解决问题!只是证明只有一个答案的非常古老的问题仍然非常有价值! :)
  • 感谢@TechnoCat
猜你喜欢
  • 1970-01-01
  • 2012-12-31
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 2011-06-16
相关资源
最近更新 更多