【问题标题】:InvocationTargetException while starting hudson on centOS在 centOS 上启动 hudson 时出现 InvocationTargetException
【发布时间】:2011-08-31 07:52:37
【问题描述】:

我使用http://hudson-ci.org/redhat/ 提供的说明安装了 Hudson。当我运行以下命令时,我得到了InvocationTargetException

root@host ~ # service hudson start

原因:java.lang.UnsatisfiedLinkError: /tmp/jna9143314259601764116.tmp: /tmp/jna9143314259601764116.tmp: 无法从共享对象映射段:不允许操作

我正在使用 Java 最新的 JDK...有什么帮助吗?

【问题讨论】:

  • 安装服务器后没有重启机器时出现问题。当我重新启动时,哈德森守护进程正在运行。所以,我现在可以重新启动它了。

标签: hudson installation centos


【解决方案1】:

这是一个看起来类似问题的链接,有一些事情可以尝试:

Exception Error when I try to initialize hudson.war

【讨论】:

    【解决方案2】:

    意识到这是一个老问题,但我偶然发现了这个问题,正在寻找其他东西。

    您不能从 JAR 文件中加载本机库。在尝试从那里加载之前,某些东西可能会将捆绑的本机库吐出到 /tmp/。你可能已经用 noexec 挂载了 /tmp/,看看 /etc/fstab:

    tmpfs /tmp tmpfs defaults,noexec,nosuid 0 0
    

    这不是一个好主意,但您可以从挂载中删除 noexec。

    如果软件不依赖于 /tmp/,另一种(稍微好一点)的解决方法是更改​​ Java tmp 目录:

    -Djava.io.tmpdir=/some/writable/directory
    

    【讨论】:

    • noexec 标志确实是罪魁祸首,太糟糕了,我自己没有问这个问题,否则我会接受这个答案:)
    猜你喜欢
    • 2013-09-30
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2011-04-15
    • 2014-05-20
    • 2014-08-23
    • 2012-11-21
    相关资源
    最近更新 更多