【问题标题】:CentOS 7 - Correctly add local package to yum repositoryCentOS 7 - 正确添加本地包到 yum 仓库
【发布时间】:2019-07-04 17:24:58
【问题描述】:

我正在尝试将本地 RPM 包添加到 yum 并安装它。 要将其添加到 yum 存储库,我运行:yum-config-manager --add-repo file:///path/to/local/package.rpm,然后运行 ​​yum install package 来安装它。但是,我得到了这个输出:

Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: ftp.rrzn.uni-hannover.de
 * epel: mirror.23media.de
 * extras: centos.mirrors.psw.services
 * nux-dextop: mirror.li.nux.ro
 * updates: mirror.ratiokontakt.de
harbottle.gitlab.io_harbottle-main_7_x86_64_                                                          | 2.9 kB  00:00:00     
file:///path/to/local/package.rpm/repodata/repomd.xml: [Errno 14] curl#37 - "Couldn't open file /path/to/local/package.rpm/repodata/repomd.xml"
Trying other mirror.


 One of the configured repositories failed (added from: file:/path/to/local/package.x86_64.rpm),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Run the command with the repository temporarily disabled
            yum --disablerepo=path_to_local_package.x86_64.rpm ...

     4. Disable the repository permanently, so yum won't use it by default. Yum
        will then just ignore the repository until you permanently enable it
        again or use --enablerepo for temporary usage:

            yum-config-manager --disable path_to_local_package.x86_64.rpm
        or
            subscription-manager repos --disable=path_to_local_package.x86_64.rpm

     5. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=path_to_local_package.x86_64.rpm.skip_if_unavailable=true

failure: repodata/repomd.xml from path_to_local_package.x86_64.rpm: [Errno 256] No more mirrors to try.
file:/path/to/local/package.x86_64.rpm/repodata/repomd.xml: [Errno 14] curl#37 - "Couldn't open file /path/to/local/package.rpm/repodata/repomd.xml"

我也尝试先运行:yum-config-manager --add-repo file:///path/to/local/package.rpm,然后是 createrepo --database /path/to/local/,但我得到了相同的输出。

有人知道如何正确地将本地 RPM 包添加到 yum 存储库吗?

谢谢!

【问题讨论】:

    标签: centos package rpm yum


    【解决方案1】:

    存储库不同于 rpm 包。存储库是包含多个 rpm 的目录。因此,如果您只想安装 rpm;你可以

    yum install /path/to/package.rpm
    

    如果您想开始托管自己的存储库;那么你需要查看createrepo。例如,本地目录可以变成这样的存储库:

    mkdir /myrepo
    cp package.rpm /myrepo
    cd /myrepo
    createrepo .
    

    现在您可以将此目录添加到yum

    yum-config-manager --add-repo file:///myrepo
    

    现在您还可以继续向此目录添加 rpm(不要忘记每次运行 createrepo)。

    【讨论】:

    • 感谢您在我通过 RPM 和 yum @chrismae 的动荡旅程中提供的帮助 :) 我尝试了您答案的第二部分,但我得到了输出(当我最终运行时:yum install tomcat8):@ 987654328@。正如您在我运行 service tomcat8 时所观察到的那样,没有找到服务。
    • 那么你需要检查你的包是否安装了tomcat8.service文件:rpm -ql tomcat8 | grep service或类似的东西。假设文件确实安装了;在运行systemctl start tomcat8之前尝试运行systemctl daemon-reload
    • 其实安装没有完成;因此缺少 tomcat8.service 文件。由于没有 gpg 密钥,该过程被中断。我跑了yum install --nogpgcheck tomcat8,它工作正常。
    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2021-04-07
    • 2012-01-26
    • 2018-09-16
    • 2016-10-09
    • 2014-10-22
    相关资源
    最近更新 更多