【问题标题】:Centos PHP server ErrorCentos PHP 服务器错误
【发布时间】:2017-11-01 05:45:23
【问题描述】:

我最近接管了一个安装了 plesk 的 Centos 服务器,但该服务器已被黑客入侵。

所有网站错误日志现在都显示错误:

[Wed May 31 12:37:12 2017] [error] [client 66.249.73.133] Premature end of script headers: index.php
[Wed May 31 12:52:32 2017] [warn] [client 40.77.167.50] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
[Wed May 31 12:52:32 2017] [error] [client 40.77.167.50] Premature end of script headers: index.php
~

我从未见过这样的事情,而且我遇到过多个堆栈溢出问题。

我试过重启,重启 httpd,所有基本的东西,甚至重置 /var/www 的文件夹权限。

谁能帮忙?

谢谢

【问题讨论】:

    标签: php centos plesk


    【解决方案1】:

    您可以尝试将 Plesk 域 PHP 处理程序从 FastCGI 切换到 PHP-FPM(甚至从 apache 切换到 Nginx)

    article 中的一些内容也可以帮助您,或者询问 cmets 中的 Plesk 人员。

    【讨论】:

      【解决方案2】:

      如另一条错误消息中所述,“脚本头结束”条目可能是由 PHP 处理程序的问题引起的。不幸的是,处理程序无法读取数据可能有多种原因。这似乎是一个 Apache 日志?你能生成一个 FastCGI 错误日志吗?由于大多数攻击只访问运行脚本的特定用户,特别是因为攻击不太可能错误配置您的 PHP 处理程序,您可以尝试查看特定站点代码的问题。权限可能是一个很好的起点,如果主目录权限没问题,也许看看其他文件。您可能想尝试创建一个新用户并简单地运行 phpinfo();来自该用户的脚本,以查看 PHP 本身是否可以工作。

      当某个帐户遭到入侵时,该用户帐户中的任何内容都不会安全。攻击者通常做的第一件事是上传 webshel​​l。从 webshel​​l,他将有权修改用户可以访问的任何文件。由于恶意软件扫描工具通常只能找到已知恶意软件的指纹,因此最好假设整个帐户已被盗用并从备份中恢复。您的问题可能比 PHP 错误更严重。

      因此,如果服务器在使用新帐户时没有问题,最好简单地丢弃该数据并努力寻找一个干净的副本进行恢复。或者,也有像 Sucuri 这样的公司可以帮助您摆脱妥协。

      【讨论】:

        猜你喜欢
        • 2016-06-19
        • 1970-01-01
        • 1970-01-01
        • 2018-08-09
        • 2015-12-02
        • 1970-01-01
        • 1970-01-01
        • 2017-07-17
        • 2016-06-18
        相关资源
        最近更新 更多