【问题标题】:jQuery-File-Upload fails with somewhat large filesjQuery-File-Upload 失败,文件有点大
【发布时间】:2019-09-04 17:15:22
【问题描述】:

尝试使用这个项目:https://github.com/blueimp/jQuery-File-Upload/

我们的应用程序服务器是 FreeBSD 11.2,带有 Apache 2.4.39 和 PHP 7.2.17。我已经下载了他们的演示并在尝试上传任何大到超过 22 秒的内容时在浏览器控制台中收到错误 net::ERR_CONNECTION_RESET。它似乎与服务器相关,因为我已将相同的演示下载到另一个 CentOS7 服务器,其中相同的文件上传成功。

虽然我已经检查了我所有的 PHP 变量的最大上传大小和内存限制等,但这个演示会受到 PHP 变量的影响吗?我在失败的服务器中发现了 RequestReadTimeout Apache 设置,在工作服务器中不存在,所以我认为这可能是罪魁祸首,但我将这个设置从...更改为...

RequestReadTimeout header=20-40,MinRate=500 body=20,MinRate=500

到这里……

RequestReadTimeout header=60-120,MinRate=500 body=120,MinRate=500

...并重新启动 Apache,但结果相同。该服务器上的开发人员认为,此问题仅在最近对服务器进行更新(包括将 Apache 2.4.33 升级到 Apache 2.4.39)后才开始。 PHP 版本没有改变,但是,还有许多其他软件包更新以及 FreeBSD 操作系统的安全补丁。有人能建议什么可以解决这个问题吗?

--更新--

好的,这很容易复制。我用全新安装的 FreeBSD 11.2、Apache 2.4.39 和这个项目的演示启动了一个 VM。我在演示应用中调整了这些设置,以允许上传大型 mp4 视频...

acceptFileTypes: /(\.|\/)(gif|jpe?g|png|mp4)$/i,
maxFileSize: 999000000,

...在下载约 493MB 的 mp4 文件的 22 秒后收到相同的Unknown error。 Apache 中必须有一个设置需要允许更多时间或其他限制。也许在 2.4.33 和 2.4.39 之间的某个地方对 FreeBSD Apache 2.4 端口进行了更改。我的开发人员说这一切都是在那次更新之后开始的。

【问题讨论】:

    标签: jquery-file-upload apache2.4 php-7.2


    【解决方案1】:

    嗯,Apache 中的RequestReadTimeout 设置是罪魁祸首。我必须完全禁用,现在它可以工作了。

    【讨论】:

    • 这里一样,似乎是 2.4.39 引入了这个问题。我们有一个 Linux Ami 在升级到 2.4.39 后遇到大文件上传问题,但我仍然不清楚为什么停止工作。看文档2.4.39刚刚介绍了握手超时,但是默认为0,其余都一样..
    【解决方案2】:

    同样的问题 - 要修复,在 Centos 7 系统上,注释掉这一行: LoadModule reqtimeout_module 模块/mod_reqtimeout.so 从 00-base.conf 文件,然后重启 httpd

    【讨论】:

      猜你喜欢
      • 2014-05-28
      • 2012-10-23
      • 2014-06-06
      • 2020-12-08
      • 1970-01-01
      • 2013-08-02
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多