【问题标题】:WSO2 ESB cannot update configurationWSO2 ESB 无法更新配置
【发布时间】:2015-04-14 21:19:30
【问题描述】:

我们无法更新最近安装的 WSO2 ESB 4.8.1 的配置 完全相同的错误发生在 Windows 7 和 Windows 2008 R2(3 台 PC 测试)中。 jre7 和 jdk1.7.0_51 测试。

安装后,只需在管理控制台(Chrome、Firefox 或资源管理器)的“服务总线配置”页面中按“更新”按钮,即使不进行任何更改,也会弹出窗口错误“存在错误你的配置”。

ESB 日志通知

WARN - MultiXMLConfigurationSerializer Error while attempting to lock the file: registry.xml
        java.io.IOException: Access is denied
                at sun.nio.ch.FileDispatcherImpl.lock0(Native Method)
                at sun.nio.ch.FileDispatcherImpl.lock(FileDispatcherImpl.java:86)
        ...
WARN - MultiXMLConfigurationSerializer Unable to acquire lock on file: registry.xml
WARN - MultiXMLConfigurationSerializer File: registry.xml is not writable

可能是“C:\esb\wso2esb-4.8.1\repository\conf\registry.xml”

我们可以使用记事本手动编辑文件。我们甚至冒险将权限更改为“所有人”,但问题仍然存在。

有什么线索吗?谢谢!

【问题讨论】:

    标签: java configuration wso2 esb file-locking


    【解决方案1】:

    在 ESB 中的 registry.xml 文件中,是否设置为:

     <readOnly>true</readOnly> ,
    

    如果是,请更改为 false。

    【讨论】:

      猜你喜欢
      • 2017-07-29
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2018-12-20
      • 1970-01-01
      • 2012-08-30
      • 2014-04-23
      相关资源
      最近更新 更多