【问题标题】:Docker zookeeper image unable to connect to sheepkiller/kafka-manager imageDocker zookeeper 镜像无法连接至sheepkiller/kafka-manager 镜像
【发布时间】:2018-06-19 16:03:07
【问题描述】:

我正在使用两张图片 sheepkiller/kafka-manager/(来自 Yahoo Inc 的工具),但这张图片是由具有怪异幽默感的人制作的,但它的评价很好。

还有zookeeper

我启动 ZooKeeper

docker run --it --restart always -d zookeeper

然后尝试启动apache管理器

docker run -it --rm  -p 9000:9000 -e ZK_HOSTS="your-zk.domain:2181" -e APPLICATION_SECRET=letmein sheepkiller/kafka-manager

文件说:

(如果没有定义ZK_HOSTS,默认值已经设置为“localhost:2181”)

错误:

发起客户端连接,connectString=localhost:2181 sessionTimeout=60000 watcher=org.apache.curator.ConnectionState@7bf272d3 [信息] o.a.z.ClientCnxn - 打开与服务器 localhost/127.0.0.1:2181 的套接字连接。不会尝试使用 SASL 进行身份验证(未知错误) [信息] k.m.a.KafkaManagerActor - zk=localhost:2181 [信息] k.m.a.KafkaManagerActor - baseZkPath=/kafka-manager [警告] o.a.z.ClientCnxn - 会话 0x0 用于服务器 null、意外错误、关闭套接字连接并尝试重新连接

我在 Windows 10 上使用Docker version 17.12.0-ce, build c97c6d6。我尝试了几种不同的方法,但均未成功。我假设端口存在问题,我 zookeeper config file/sheepkiller/kafka-manager/dockerfile/ 但如果确实是这种情况,我不知道在我已经提取它们之后如何更改这些图像。

【问题讨论】:

    标签: docker apache-zookeeper


    【解决方案1】:

    以下应该可以正常工作:

    docker network create zookeeper-net
    docker run -it --restart always -p 2181:2181 --network zookeeper-net --name zookeeper -d zookeeper
    docker run -it --rm  -p 9000:9000 -e ZK_HOSTS="zookeeper:2181" -e APPLICATION_SECRET=letmein sheepkiller/kafka-manager
    

    更新

    还有一个compose file 来设置一切。我建议你使用它。

    docker-compose up -d
    

    【讨论】:

    • 错误 Background exception was not retry-able or retry gave uporg.apache.curator.CuratorConnectionLossException: KeeperErrorCode = ConnectionLoss 感谢您的努力。
    • @Drew1208 更新了答案,您可以使用开发人员为 kafka 映像提供的 Docker compose 文件。这应该完美无缺。
    • PS C:\Users\me\Documents\yahoo-monitoring> docker-compose up ERROR: Can't find a suitable configuration file in this directory or parent. Are you in the right directory? Supported filenames: docker-compose.yml, docker-compose.yaml 我创建了一个目录,然后是一个 yml 文件,并使用正确的设置对其进行了编辑,但无济于事。
    • @Drew1208 你需要复制/下载这个文件github.com/sheepkiller/kafka-manager-docker/blob/master/…并将其命名为docker-compose.yml,然后在同一目录下运行docker-compose up -d
    • 现在我在创建集群时得到了这个Yikes! Ask timed out on [ActorSelection[Anchor(akka://kafka-manager-system/), Path(/user/kafka-manager)]] after [5000 ms]。男人在这里待了2天。 github.com/yahoo/kafka-manager/issues/401我试过了,但没有。
    猜你喜欢
    • 1970-01-01
    • 2017-06-01
    • 1970-01-01
    • 2019-01-14
    • 2019-02-04
    • 1970-01-01
    • 2021-12-25
    • 2017-09-15
    • 2020-11-14
    相关资源
    最近更新 更多