【发布时间】:2019-05-18 05:07:57
【问题描述】:
yum 运行良好,但在服务器上安装 cpanel 后 yum 无法执行任何操作 还有这个错误
cpanel-addons-production-feed | 2.9 KB 00:00
无法检索镜像列表http://httpupdate.cpanel.net/cpanel-plugins-clatest-x86_64-mirrorlist 错误是
14:HTTP 错误 404 - 未找到
配置的存储库之一失败(未知), 并且 yum 没有足够的缓存数据来继续。此时唯一 百胜可以做的安全的事情是失败。有几种方法可以“解决”这个问题:
1. Contact the upstream for the repository and get them to fix the problem.
2. Reconfigure the baseurl/etc. for the repository, to point to a working
upstream. This is most often useful if you are using a newer
distribution release than is supported by the repository (and the
packages for the previous distribution release still work).
3. Disable the repository, so yum won't use it by default. Yum will then
just ignore the repository until you permanently enable it again or use
--enablerepo for temporary usage:
yum-config-manager --disable <repoid>
4. Configure the failing repository to be skipped, if it is unavailable.
Note that yum will try to contact the repo. when it runs most commands,
so will have to try and fail each time (and thus. yum will be be much
slower). If it is a very temporary problem though, this is often a nice
compromise:
yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true
找不到 repo 的有效 baseurl:cpanel-plugins/latest/x86_64
【问题讨论】:
-
欢迎来到 SO,阅读 tour 可能会有所帮助。这个问题可能属于姊妹站点 ServerFault.com 或 unix.stackexchange.com