【问题标题】:Getting error when trying to launch node.js app with PM2 Cluster尝试使用 PM2 集群启动 node.js 应用程序时出错
【发布时间】:2018-12-20 09:13:02
【问题描述】:

在 Ubuntu 服务器中,我无法使用 PM2 在集群模式下运行 node.js 应用程序。

我使用的命令是:

PM2 start server.js --name Server -i max

当我列出 PM2 进程时,我可以看到 Server 有错误状态。 我尝试查看 PM2 生成的日志文件,但它是空的。

但是,我可以在没有集群模式的情况下运行相同的 server.js :

PM2 启动 server.js --name 服务器

【问题讨论】:

    标签: node.js pm2


    【解决方案1】:

    执行PM2 Kill 并重新启动所有服务是上述问题的解决方案。

    【讨论】:

      【解决方案2】:

      您也可以使用pm2 restart Server 重新启动它

      如果你使用pm2 kill,你只会杀死所有进程,之后清理我建议使用pm2 flush,这样所有的日志文件都会被重置

      【讨论】:

      • pm2 restart server 在我的情况下不起作用。在做 pm2 kill 之前我用过几次
      【解决方案3】:

      我也经历过同样的情况,但在我的情况下,pm2 显示错误状态是我的代码中的错误原因。 使用下面的命令

      pm2 logs
      

      pm2 logs 命令通过显示一些提示来帮助我检查错误发生的确切位置。

      如果一切正常,pm2 list 将在线显示状态。

      您可以使用以下命令检查 pm2 运行的端口(不仅是 pm2,还包括所有进程)

      sudo netstat -tulpn
      

      【讨论】:

        猜你喜欢
        • 2021-07-04
        • 1970-01-01
        • 2014-07-14
        • 2016-12-10
        • 2020-12-26
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        相关资源
        最近更新 更多