【发布时间】:2017-04-25 18:26:21
【问题描述】:
我正在努力让 Nextcloud 通过 SSL 接受更大的文件(最大 512MB)。
到目前为止我所拥有的是:
在 /etc/apache2/conf-enabled/owncloud.conf:
Alias /nextcloud "/var/www/nextcloud/"
<Directory "/var/www/nextcloud">
Options +FollowSymLinks
AllowOverride All
<IfModule mod_dav.c>
Dav off
</IfModule>
LimitRequestBody 201048600
SSLRenegBufferSize 201048600
SetEnv HOME /var/www/nextcloud
SetEnv HTTP_HOME /var/www/nextcloud
</Directory>
<Directory "/var/www/nextcloud/data/">
# just in case if .htaccess gets disabled
Require all denied
</Directory>
在 /etc/php5/apache2/php.ini 中(由 phpinfo() 确认并在 nextcloud 管理设置中设置)
post_max_size = 512M
upload_max_filesize = 512M
但是,仍然无法上传较大的文件(413 请求实体太大)。 它甚至不适用于 6 MB 文件...
我是否缺少某种特殊设置?
【问题讨论】:
-
你重启了网络服务器吗?
标签: php apache owncloud nextcloud