【问题标题】:AWS Bitnami EC2 and EC2 fails to start with Service UnavailableAWS Bitnami EC2 和 EC2 无法以 Service Unavailable 启动
【发布时间】:2021-05-12 13:11:16
【问题描述】:

我目前有一个附加了 10gb 通用存储的 AWS Bitnami EC2 Wordpress 实例。直到最近,当我在页面上收到以下错误时,一切都运行良好:

服务不可用
由于维护停机或容量问题,服务器暂时无法满足您的请求。 请稍后再试。

此外,在运行时遇到了 503 Service Unavailable 错误 尝试使用 ErrorDocument 来处理请求。

我继续检查系统日志并得到以下信息:

[  151.389085] bitnami[1159]: Please see below for details
[  151.392234] bitnami[1159]: http://docs.fedoraproject.org/en-US/Fedora/13/html/SELinux_FAQ/index.html#id3037154
[  151.396103] bitnami[1159]: ## 2021-02-08 10:21:07+00:00 ## INFO ## Running /opt/bitnami/var/init/post-start/040_update_welcome_file...
[  151.400843] bitnami[1159]: ## 2021-02-08 10:21:07+00:00 ## INFO ## Running /opt/bitnami/var/init/post-start/050_bitnami_credentials_file...
[  151.416962] bitnami[1159]: ## 2021-02-08 10:21:07+00:00 ## INFO ## Running /opt/bitnami/var/init/post-start/060_start_gonit...
[  151.426036] bitnami[1159]: Starting gonit daemon
[  151.435518] bitnami[1159]: write /var/lib/gonit/state: no space left on device
[  151.438242] bitnami[1159]: write /var/lib/gonit/state: no space left on device
[  151.440614] bitnami[1159]: write /var/lib/gonit/state: no space left on device
[  151.444201] bitnami[1159]: ## 2021-02-08 10:21:07+00:00 ## INFO ## Running /opt/bitnami/var/init/post-start/070_clean_metadata...
[[0;1;31mFAILED[0m] Failed to start LSB: bitnami init script.
See 'systemctl status bitnami.service' for details.
[[0;32m  OK  [0m] Reached target Multi-User System.
         Starting Execute cloud user/final scripts...
[[0;32m  OK  [0m] Reached target Graphical Interface.
         Starting Update UTMP about System Runlevel Changes...
[[0;32m  OK  [0m] Started Update UTMP about System Runlevel Changes.
[  151.981648] cloud-init[2275]: OSError: [Errno 28] No space left on device
[  151.985418] cloud-init[2275]: During handling of the above exception, another exception occurred:
[  151.988142] cloud-init[2275]: Traceback (most recent call last):
[  151.996571] cloud-init[2275]:   File "/usr/bin/cloud-init", line 9, in <module>
[  151.999040] cloud-init[2275]:     load_entry_point('cloud-init==19.2', 'console_scripts', 'cloud-init')()
[  152.001985] cloud-init[2275]:   File "/usr/lib/python3/dist-packages/cloudinit/cmd/main.py", line 893, in main
[  152.005271] cloud-init[2275]:     get_uptime=True, func=functor, args=(name, args))
[  152.008071] cloud-init[2275]:   File "/usr/lib/python3/dist-packages/cloudinit/util.py", line 2525, in log_time
[  152.011326] cloud-init[2275]:     ret = func(*args, **kwargs)
[  152.020732] cloud-init[2275]:   File "/usr/lib/python3/dist-packages/cloudinit/cmd/main.py", line 648, in status_wrapper
[  152.023872] cloud-init[2275]:     atomic_helper.write_json(status_path, status)
[  152.026501] cloud-init[2275]:   File "/usr/lib/python3/dist-packages/cloudinit/atomic_helper.py", line 46, in write_json
[  152.032550] cloud-init[2275]:     omode="w", mode=mode)
[  152.034569] cloud-init[2275]:   File "/usr/lib/python3/dist-packages/cloudinit/atomic_helper.py", line 39, in write_file
[  152.038544] cloud-init[2275]:     raise e

不止于此,但我不断收到 “设备上没有剩余空间” 错误。如果愿意提供帮助的人有兴趣,日志中还有很多内容。

我还应该声明,由于某个问题,我无法再访问 ssh 密钥,但我强烈认为它无法正常工作,因为我创建了此实例和卷的映像,每次都返回“连接超时” SSH 尝试。

我的智慧到此为止。任何帮助将不胜感激。

【问题讨论】:

    标签: amazon-web-services amazon-ec2 bitnami


    【解决方案1】:

    这里是 Bitnami 工程师,

    正如您所说,问题是机器上没有剩余空间,因此您需要删除您拥有的数据或增加磁盘大小。

    首先,让我们了解一下Bitnami安装中包含更多数据的文件夹的更多信息

    cd /opt/bitnami
    du -h -d 1
    

    https://docs.bitnami.com/aws/faq/troubleshooting/troubleshoot-server-performance/

    如果 MySQL 是空间较大的文件夹,可以尝试禁用数据库中的二进制日志以节省一些空间

    • 停止数据库
    sudo /opt/bitnami/ctlscript.sh stop mysql
    
    • 在 MySQL 的配置中禁用二进制日志记录
    [mysqld]
    disable_log_bin
    ...
    
    • 重新启动服务器并从实例中清除旧文件

    更多信息在这里:https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/disable-binary-logging-mysql/

    但是,如果您无法删除实例中的任何数据,则需要增加实例中的磁盘大小。您将需要访问 AWS EC2 控制台,确定实例正在使用的卷并增加卷的大小

    您可以在此处了解更多信息:https://docs.bitnami.com/aws/how-to/modify-ebs-volume/

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 2017-12-17
      • 2023-03-14
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2011-10-29
      • 1970-01-01
      • 2014-10-07
      相关资源
      最近更新 更多