【发布时间】:2021-03-28 01:42:15
【问题描述】:
我正在尝试连接到托管在 AWS 上的 redis 服务器。我使用我的私钥 ssh 进入实例,安装并运行服务器。现在我想使用实例的公共 dns 和端口 6379(服务器正在运行的端口)访问服务器。我已经使用0.0.0.0/0 和::/0 将端口 6379 添加到安全组,但是当我在此端口上 telnet 时,我得到:
Trying [PUBLIC-DNS]...
telnet: connect to address [PUBLIC-DNS]: Connection refused
telnet: Unable to connect to remote host
任何帮助将不胜感激。
【问题讨论】:
-
如果连接被彻底拒绝,那么服务器没有监听该接口上的端口,或者实例本身的 iptables 或 firewalld 阻止了流量。我建议检查一下
-
我应该在哪里检查这些?
-
正如我所说,在实例上。 SSH 进入并检查这些设置
-
失败需要一些时间(这表明没有网络连接),还是立即失败(表明访问被拒绝)?
-
立即失败
标签: amazon-web-services amazon-ec2 aws-security-group