【发布时间】:2013-07-10 20:52:10
【问题描述】:
我使用的是 tomcat7,我将它的默认端口从 8080 更改为 80。 之后,当我尝试重新启动服务器时,它不会启动。 启动失败。
我更改了 /var/lib/tomcat7/conf/server.xml 中的端口 在更改它时,我修改了 server.xml 的文件权限,因为它之前是只读的。 我试图查看 /var/log/tomcat7/catalina.xx.xx.xxxx 中的 catalina 日志 发现我更改了 server.xml,现在 tomcat 无法从 server.xml 中找到上下文
日志指出“严重:无法从 server.xml 加载服务器上下文” 抱歉,我目前无法提供实际日志。 我真的很困惑,我只是改变了端口,没有别的。 即使还原更改也不会启动 tomcat。
非常感谢您在此问题上提供的任何帮助。
我在亚马逊 ec2 实例上使用 ubuntu 12.04 LTS 64 位服务器。 我尝试检查那些可能在端口 80 或 8080 上运行的进程并杀死它们,但这也没有帮助。
【问题讨论】:
-
您是否以 root 身份启动它? 1024以下的端口只能由管理员/root用户绑定。
-
是的,我以 root 身份启动它。
-
这可能是由 server.xml 上的权限更改引起的。也许tomcat没有更多的文件访问权限。您无需更改文件的权限。使用 sudo :)
-
感谢您的回复,我将权限改回只读,但这也没有帮助。使用 chmod 400 server.xml 更改它
-
您确定您的 server.xml 仍然是有效的 XML 吗?可能是笔误?您也可以尝试下载新的 tomcat 副本并替换 server.xml
标签: tomcat