【问题标题】:Digital Ocean nginx/sites-enabled questionDigital Ocean nginx/启用站点的问题
【发布时间】:2020-05-28 23:07:36
【问题描述】:

我在终端写的时候写错了名字:

sudo ln -s /etc/nginx/sites-available/portfolio-project /etc/nginx/sites-enabled

所以当我点击这个命令时:

sudo nginx -t

它提出了:

nginx: [emerg] open() "/etc/nginx/sites-enabled/portfolio-project" failed (2: No such file or directory) in /etc/nginx/nginx.conf:62

nginx:配置文件/etc/nginx/nginx.conf测试失败

问题是 - 我如何删除修改这个投资组合项目,因为那是错误的文件夹级别。我已经写了这个命令来说 porfolio 这是正确的名称,但现在我不知道如何删除“portfolio-project”的东西。

非常感谢! RG

【问题讨论】:

  • 嗨!您不必将此添加到问题中,但是当您在/etc/nginx/sites-enabled/ 中发出ls -l 命令时会看到什么?
  • 它说:默认投资组合。投资组合项目。 (所以我想删除投资组合项目,但我该怎么做?)谢谢!
  • 正如@icedwater 建议的那样。使用ls -l 或ls -la(查看隐藏文件)。此外,您可能需要运行 vi sudo nano /etc/nginx/sites-available/portfolio-project 在 vi​​ 编辑器中打开此文件,或者您可以在您选择的编辑器中打开它。确保您在该文件中具有正确的 nginx 配置。 10 次中有 9 次出现问题是因为这些文件配置不正确...

标签: python nginx digital-ocean


【解决方案1】:

尝试: 您必须编辑etc/nginx/sites-available/portfolio-project 文件。使用 vi 或 nano(我在下面使用 vi):

sudo vi /etc/nginx/sites-available/portfolio-project 

然后换行:

include proxy_params;

到:

include /path/to/proxy_params

【讨论】:

    【解决方案2】:

    如果您在创建初始 软 链接 (ln -s) 时输入错误,您可以安全地删除该链接,而不会影响原始文件:

    sudo ln -s /path/oops /destination  # oops
    rm /destination/oops
    sudo ln -s /path/correct /destination
    

    请不要尝试使用关键文件和硬链接(无-s)。

    【讨论】:

      【解决方案3】:

      您可以使用“rm”命令删除错误的软链接,就好像它是一个文件一样。例如,如果你这样做了

      sudo ln -s /etc/nginx/sites-available/portfolio-project /etc/nginx/sites-enabled
      

      那么你必须执行以下命令

      sudo rm /etc/nginx/sites-enabled/portfolio-project
      

      然后简单地重新链接正确的文件

      sudo ln -s /etc/nginx/sites-available/correct-one /etc/nginx/sites-enabled
      

      希望这会有所帮助!

      【讨论】:

        猜你喜欢
        • 1970-01-01
        • 2021-02-28
        • 1970-01-01
        • 1970-01-01
        • 2020-06-27
        • 1970-01-01
        • 2016-07-26
        • 1970-01-01
        • 1970-01-01
        相关资源
        最近更新 更多