【发布时间】:2017-10-09 04:30:20
【问题描述】:
使用 capistrano 部署时出错
DEBUG [aaaad896] Command: cd /home/dev/PROJECT-NAME/current && ( export RAILS_ENV="production" ; ~/.rvm/bin/rvm default do bundle exec unicorn -c /home/dev/PROJECT-NAME/current/config/unicorn.rb -E deployment -D )
DEBUG [aaaad896] master failed to start, check stderr log for details
(Backtrace restricted to imported tasks)
cap aborted!
SSHKit::Runner::ExecuteError: Exception while executing as dev@XX.XXX.XXX.XX: bundle exit status: 1
bundle stdout: Nothing written
bundle stderr: master failed to start, check stderr log for details
其他日志。
Errno::EADDRINUSE: Address already in use - bind(2) for 0.0.0.0:8080
/home/dev/PROEJCT-NAME/shared/bundle/ruby/2.3.0/gems/unicorn-5.1.0/lib/unicorn/socket_helper.rb:149:in `bind'
unicorn.rb 文件:unicorn.rb
deploy.rb 文件 deploy.rb
默认(nginx/site-enables/default)文件:default
每次我在 capistrano 中遇到此错误时都会重新启动独角兽。那么我该如何解决呢?
【问题讨论】:
标签: ruby-on-rails ruby nginx unicorn capistrano3