【发布时间】:2016-02-16 05:49:39
【问题描述】:
我正在遵循this link 在数字海洋上部署一个 Rails 应用程序。当我遵循确切的步骤时,它工作得很好。但后来我意识到 github 存储库是公开的。我应该把它作为私人的。我创建了一个私有存储库并在本地更改了远程源。我将 ssh 密钥放在新的私有存储库中。删除了服务器中的旧应用程序文件夹。然后尝试从远程存储库克隆,但它要求输入密码。 (它应该使用 ssh 密钥??)。
我还更改了 deploy.rb 和 nginx.conf 以反映远程存储库的更改,然后给出了这个命令,cap production deploy:initial,但由于 git 中的身份验证失败,它失败了。
为什么会失败?为什么ssh key不生效?
【问题讨论】:
-
我没有使用过digitalocean,但是如果您使用
https://github.com/...地址而不是git://,就会出现这种情况 -
你在这方面有什么进展吗?找到解决方案还是仍有问题?
标签: ruby-on-rails git nginx ssh digital-ocean