【问题标题】:Nginx + Passenger + Rails Server ErrorNginx + 乘客 + Rails 服务器错误
【发布时间】:2015-04-01 06:45:18
【问题描述】:

当我尝试访问我的服务器时,我收到以下错误

App 13379 stdout:
App 13379 stdout:
[ 2015-02-02 05:28:59.1782 13226/7fb5d9699700 Pool2/Implementation.cpp:287 ]: Could not spawn process for application /var/www/noise: An error occured while starting up the pr$
  Error ID: b4c47933
  Error details saved to: /tmp/passenger-error-U83DbV.html
  Message from application: cannot load such file -- bundler/setup (LoadError)
  /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
  /usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require'
  /usr/lib/ruby/vendor_ruby/phusion_passenger/loader_shared_helpers.rb:263:in `block in run_load_path_setup_code'
  /usr/lib/ruby/vendor_ruby/phusion_passenger/loader_shared_helpers.rb:366:in `running_bundler'
  /usr/lib/ruby/vendor_ruby/phusion_passenger/loader_shared_helpers.rb:261:in `run_load_path_setup_code'
  /usr/share/passenger/helper-scripts/rack-preloader.rb:100:in `preload_app'
  /usr/share/passenger/helper-scripts/rack-preloader.rb:158:in `<module:App>'
  /usr/share/passenger/helper-scripts/rack-preloader.rb:29:in `<module:PhusionPassenger>'
  /usr/share/passenger/helper-scripts/rack-preloader.rb:28:in `<main>'


[ 2015-02-02 05:28:59.1863 13226/7fb5d7363700 agents/HelperAgent/RequestHandler.h:2306 ]: [Client 19] Cannot checkout session because a spawning error occurred. The identifier$

NginX 配置内容

user www-data;
worker_processes 4;
pid /run/nginx.pid;

events {
        worker_connections 768;
        # multi_accept on;
}

http {

        ##
        # Basic Settings
        ##

        sendfile on;
        tcp_nopush on;
        tcp_nodelay on;
        keepalive_timeout 65;
        types_hash_max_size 2048;
        # server_tokens off;

        # server_names_hash_bucket_size 64;
        # server_name_in_redirect off;

        include /etc/nginx/mime.types;
        default_type application/octet-stream;

        ##
        # Logging Settings
        ##

        access_log /var/log/nginx/access.log;
        error_log /var/log/nginx/error.log;

        ##
        # Gzip Settings
        ##

        gzip on;
        gzip_disable "msie6";

        # gzip_vary on;
        # gzip_proxied any;
        # gzip_comp_level 6;
        # gzip_buffers 16 8k;
        # gzip_http_version 1.1;
        # gzip_types text/plain text/css application/json application/x-javascript text/xml application/xml application/xml+rss text/javascript;

        ##
        # nginx-naxsi config
        ##
        # Uncomment it if you installed nginx-naxsi
        ##

        # include /etc/nginx/naxsi_core.rules;

        ##
        # Phusion Passenger config
        ##
        # Uncomment it if you installed passenger or passenger-enterprise
        ##

        #Web SERVER
        server {
            server_name 104.236.218.36;
            listen 80;
            root /var/www/noise/public;
            passenger_enabled on;
        }

        # API SERVER
        server {
            server_name 104.236.218.36;
            listen 3333;
            root /var/www/noise-api/public;
            passenger_enabled on;
        }

        #passenger_root /usr/lib/ruby/vendor_ruby/phusion_passenger/locations.ini;
        #passenger_ruby /usr/bin/ruby;
        passenger_root /usr/local/rvm/gems/ruby-2.2.0/gems/passenger-4.0.58;
    passenger_ruby /usr/local/rvm/gems/ruby-2.2.0/wrappers/ruby;

        ##
        # Virtual Host Configs
        ##

        include /etc/nginx/conf.d/*.conf;
        include /etc/nginx/sites-enabled/*;
}


# mail {
#       # See sample authentication script at:
#       # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
#
#       # auth_http localhost/auth.php;
#       # pop3_capabilities "TOP" "USER";
#       # imap_capabilities "IMAP4rev1" "UIDPLUS";
#
#       server {
#               listen     localhost:110;
#               protocol   pop3;
#               proxy      on;
#       }
#
#       server {
#               listen     localhost:143;
#               protocol   imap;
#               proxy      on;
#       }
# }

更新

更改后如下

passenger_root /usr/local/rvm/gems/ruby-2.2.0/gems/passenger-4.0.58;
        passenger_ruby /usr/local/rvm/gems/ruby-2.2.0/wrappers/ruby;

收到以下错误日志

2015/02/02 06:16:06 [error] 13528#0: *3 directory index of "/var/www/noise/public/" is forbidden, client: 122.178.204.27, server: 104.236.218.36, request: "GET / HTTP/1.1", ho$

【问题讨论】:

  • 你能把 nginx.conf 文件的内容贴出来吗?
  • @CaffeineCoder 已更新:D
  • 这个命令的输出是什么 - gem install bundler
  • @CaffeineCoder 成功安装 bundler-1.7.12 解析 bundler-1.7.12 的文档 安装 bundler-1.7.12 的 ri 文档 2 秒后完成安装 bundler 的文档 1 个 gem 安装
  • 请使用 capistrano ,它比手动构建符号链接更有帮助。

标签: ruby-on-rails ubuntu nginx passenger ubuntu-14.04


【解决方案1】:

据我猜测,nginx 无法连接到您的应用程序。让我们使用Capistrano

安装 gem,然后运行 ​​- bundle exec cap install

根据我之前提出的question 要求,复制文件夹中部署和暂存文件中的内容。相应地设置地址并尝试一下。如果我能提供进一步的帮助,请让我。

【讨论】:

    【解决方案2】:

    确保您的 Nginx 配置的passenger_ruby 是您的Rails 应用程序的ruby 版本。

    如果您以乘客方式安装并使用 RVM,它将是 usr/local/rvm/gems/ruby-2.1.2/

        passenger_root /your-ruby-version/gems/passenger-4.0.50;
        passenger_ruby /your-ruby-version/wrappers/ruby;
    

    希望这些信息会有所帮助:)

    【讨论】:

    • 对不起,我不明白。我已经使用 RVM 在服务器上安装了 Ruby。
    • 当前配置passenger_root /usr/lib/ruby/vendor_ruby/phusion_passenger/locations.ini;乘客红宝石 /usr/bin/ruby;
    • 我更改了它,现在我收到以下错误 2015/02/02 06:16:06 [error] 13528#0: *3 directory index of "/var/www/noise/public /”被禁止,客户端:122.178.204.27,服务器:104.236.218.36,请求:“GET / HTTP/1.1”,ho$
    • 尝试 chmod 你的项目文件夹。
    猜你喜欢
    • 1970-01-01
    • 2011-05-31
    • 2018-02-14
    • 2018-07-11
    • 2013-06-19
    • 2011-09-09
    • 1970-01-01
    • 2015-07-15
    • 2023-03-05
    相关资源
    最近更新 更多