【问题标题】:Cannot connect to remote interpreter in Phpstorm 9无法连接到 Phpstorm 9 中的远程解释器
【发布时间】:2015-10-13 16:39:09
【问题描述】:

我在设置下设置了一个远程服务器(Ubuntu 14),部署名称为 RemoteServer,通过 SSH + 私钥连接。我可以成功浏览远程文件,编辑,上传下载等。 在工具下,启动 SSH-Session,我可以成功使用终端。

但是

当我尝试将此远程服务器添加到语言和框架、PHP、解释器时 - 我无法让它工作。 (我有与 Vagrant 工作正常的等效设置 - 我有名为 Vagrant-SSH 的部署服务器并在我的项目中使用解释器)。在解释器对话框中,任何连接到服务器的尝试都会失败。 单击部署主机 URL: - ssh://me@remotesite.com:22 - 弹出测试 SFTP 连接对话框 - 连接到“mysite.com”失败。连接失败。但是,当我第一次添加这个 php 解释器时,它成功地将所有帮助程序上传到 ~/.phpstorm_helpers。但随后它声称 php 未安装在 /usr/bin/php (该命令确实有效)。再次单击浏览按钮告诉我连接到 mysite.com 时出错。我还尝试设置具有相同结果的 SSH 凭据(我经常收到与不支持 aes256-cbc 相关的密钥错误 - [我尝试了同一密钥的 PUTTY .ppk 和 OPEN-SSH 版本])。

什么可能导致此问题?还记得,在 Phpstorm 的其他部分,这个 SSH 配置可以正常工作吗?

可能与权限有关吗?我在服务器上没有高级服务器管理员权限,但足以应付日常的 sftp + shell。好吧,我尝试在我的 Phpstorm 终端中运行(基于 Start SSH-Session->RemoteServer)

   cd .phpstorm_helpers
    php phpinfo.php

它工作正常 - 吐出相关的 xml。所以我有足够的权限来运行帮助程序并获得有用的结果。

这真的与 Java 处理 ssh 密钥有关吗?正如所指出的,在 phpstorm 的其他部分它工作正常。

【问题讨论】:

  • 1) 请为部署操作启用额外的日志记录(包括 SSH 操作) 2) 连同您的 idea.log 文件 (Help | Show Log in...) 一起提交支持票。如果没有关于那里发生什么异常的日志和提示,就不可能根据你的描述给你任何具体的建议(主要是因为它在这里有效而在那里失败)。

标签: phpstorm


【解决方案1】:

这已在 9.0.1 中修复 Youtrack

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 2016-07-19
    • 1970-01-01
    • 2015-09-11
    • 1970-01-01
    • 1970-01-01
    • 2015-02-17
    • 2017-04-04
    • 2022-01-13
    相关资源
    最近更新 更多