【问题标题】:ASP.NET Publish FTP IssuesASP.NET 发布 FTP 问题
【发布时间】:2014-01-20 08:40:53
【问题描述】:

我正在与我的 ASP.NET 托管公司合作。我使用 Visual Studio 2012 .NET Framework 4.5 创建了一个简单的 Web 应用程序

起初我尝试使用 web deploy 来发布我的网站,即使使用他们的文档也无法完成。然后他们让我使用 FTP 选项发布。效果很好,我可以发布到我的域的根目录。但是当我尝试发布到不同的文件夹 domain.com/apps/root/thisapp 时,Visual Studio 会发布而没有错误,但是当我导航到 URL 时,我收到了 500 服务器错误。

现在我被要求只使用 FTP 程序并将我的所有文件复制到我想要该站点所在的目录,所以我这样做了,现在我的 web.config 文件上出现“配置错误”:

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS.

Source Error:


Line 21:       </namespaces>
Line 22:     <controls><add assembly="Microsoft.AspNet.Web.Optimization.WebForms" namespace="Microsoft.AspNet.Web.Optimization.WebForms" tagPrefix="webopt" /></controls></pages>
Line 23:     <authentication mode="Forms">
Line 24:       <forms loginUrl="~/Account/Login" timeout="2880" defaultUrl="~/" />
Line 25:     </authentication>

我没有在本地收到此错误,也没有在我的域根目录发布该站点时收到此错误。我的想法不多了,看来我的主人也是。有谁知道您如何将网站发布到 ASP.NET 服务器上的任何目录?

还有人可以帮助我缩小导致此错误的原因吗?托管支持,说它是代码或我的项目。但是我不这么认为,因为它在本地和域的根目录下都可以正常工作。我认为 IIS 或我的文件夹的权限存在问题。

【问题讨论】:

  • 那条线上的错误是什么?
  • @MikeChristensen 抱歉,这是一个配置错误。
  • 它只是说“配置错误”,没有别的?确实需要有人为 那个错误消息向 .NET 团队大喊大叫。
  • @MikeChristensen 是的,还有更多内容可以让我编辑我的帖子,对此感到抱歉。

标签: asp.net .net visual-studio-2012 ftp hosting


【解决方案1】:

【讨论】:

    【解决方案2】:

    Web.config 的某些部分仅允许在 IIS 层次结构中的特定级别使用。基本级别为 Machine、Application 和 Everywhere(具体定义见 here)。

    问题在于您的 web.config 包含一些仅在机器或应用程序级别中允许的部分。机器几乎不受限制(除非您拥有机器,但您有托管服务提供商)。应用程序要求您的文件夹是 IIS 站点的根目录,或者是 IIS 中标记为应用程序的子目录 (possibly relevant link)。

    尝试询问您的提供商如何指定要标记为应用程序的目录。如果他们不允许这样做,您将不得不挖掘 web.config 并找出哪些设置具有此安全级别。

    【讨论】:

    • 你的观点也很好。这次真是万分感谢。我已经联系了我的主人,并与他们分享了这个问题。我会告诉你他们回来的。
    【解决方案3】:

    不确定“网络部署”是否是指 Web Matrix 3。如果没有,它应该可以解决您的问题。我在托管公司遇到了这个问题,我使用的是 ASP.NET MVC 4 互联网应用程序。 http://www.microsoft.com/web/webmatrix/

    希望对你有帮助,

    摇滚

    【讨论】:

    • 在我试一试之前从未听说过这个网络矩阵。这就是我在这里指的:blog.arvixe.com/arvixe-asp-net-web-deployment-how-to-guide
    • 祝你好运!让我知道进展如何,如果您需要任何帮助,请在这里告诉我 =]
    • 我无法使用网络部署。我必须使用 FTP。在网络部署下(即使使用网络矩阵 3)它说我的用户名和/或密码错误。网络矩阵看起来就像发布者内置的视觉工作室。我将如何告诉网络矩阵发布到我的域下的文件夹?在站点路径或目标 URL 中?或者同时为站点路径 /domain.com/wwwroot/somefolder 和目标 URL domain.com/somefolder?
    猜你喜欢
    • 1970-01-01
    • 1970-01-01
    • 2022-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多