【问题标题】:mongodb cannot start with mongo.confmongodb 不能以 mongo.conf 开头
【发布时间】:2018-02-22 22:42:30
【问题描述】:

操作系统是深度操作系统,我可以使用

/home/soft/mongodb/bin/mongod --dbpath=/home/soft/mongodb/data/db --logpath=/home/soft/mongodb/log/mongodb.log --logappend --port 27017 --fork

会正常启动mongodb,但是当我使用

mongod --config /usr/local/mongodb/mongodb.conf 会导致像这张图片的一些问题 enter image description here 如果图片不显示,错误代码:

root@deepin:/# mongod -config /home/soft/mongodb/mongodb.conf 
about to fork child process, waiting until server is ready for connections.
forked process: 3196
ERROR: child process failed, exited with error number 100

运行后的日志文件图片是这样的 enter image description here

【问题讨论】:

    标签: linux mongodb


    【解决方案1】:
    1. 如果创建了日志,请尝试发布日志。
    2. 检查所创建文件夹的权限,即确保文件夹被创建为sudo install-mongodb-child-process-failed-exited-with-error-number-100
    3. 也试试这个mongodb-wont-start-error-child-process-failed-exited-with-error-number-100

    【讨论】:

    • 哦,还是这个情况,最新编辑有log图
    • 谢谢,已经解决了,最近的异常退出导致问题,我删除了data目录,重新创建data/db,正常启动mongod。
    猜你喜欢
    • 2019-05-19
    • 2021-12-20
    • 2013-11-07
    • 2017-03-28
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2017-02-07
    • 2020-03-02
    相关资源
    最近更新 更多