【发布时间】:2020-04-09 15:59:10
【问题描述】:
我的应用程序在我的开发工作站上的 IIS Express 中运行良好,但我无法将它部署到 IIS。当我浏览到应用程序时收到以下错误:
HTTP 错误 500.30 - ANCM 进程中启动失败
Windows 事件日志中没有太多内容:
Application '/LM/W3SVC/2/ROOT' with physical root 'c:\inetpub\cashflow\' failed to load coreclr. Exception message:
Error occured when initializing inprocess application, Return code: 0x80008083
据我所知,从命令行调用时应用程序运行良好:
以下是我在失败的请求跟踪中看到的内容:(我对为什么文件被标识为 F: 感到有点困惑……这台机器上没有 F:\ 驱动器!)
抱歉,我无法提供完整的跟踪 XML,因为它超过了 100,000 个字符。如果您有什么特别想看的,请告诉我,我会尽力提供相关的 sn-p。感谢您提供的任何建议!
【问题讨论】:
-
根据你安装的ASP.NET Core模块,你可以在GitHub上找到相关的源码,github.com/aspnet/AspNetCore/tree/v3.0.0/src/Servers/IIS/…然后结合行号和错误码,你应该找出原因了。跨度>
-
有时这个错误可能是循环依赖注入错误。
标签: .net-core iis-8 .net-core-3.0