【发布时间】:2014-01-04 16:23:21
【问题描述】:
我已经在我们之前的 LiquidWeb LAMP 堆栈中使用了这些 cronjobs,它运行良好。现在在我们的新 AWS 设置中,它根本无法工作。
*/1 * * * * /usr/bin/curl --silent --compressed http://website.com/reader.php
*/1 * * * * /usr/bin/curl --silent --compressed http://website.com/process/
*/1 * * * * /usr/bin/curl --silent --compressed http://website.com/subscription/instagramtag
*/1 * * * * /usr/bin/curl --silent --compressed http://website.com/subscription/twittertag
*/1 * * * * /usr/bin/curl --silent --compressed http://website.com/subscription/cron_follow
*/30 * * * * /usr/bin/curl --silent --compressed http://website.com/subscription/report/
*/1 * * * * /usr/bin/curl --silent --compressed http://www.website.com/subscription/twitter
我知道这些脚本可以工作,没有 PHP 错误,而且很明显 website.com 不是真实地址。是因为我们在一个微实例上吗?我是不是服务器超载了?
【问题讨论】:
-
更正,第一个脚本运行良好。
-
系统日志是怎么说的
-
有什么错误吗?检查你的邮件。
-
为什么不通过命令行调用文件
php file.php
标签: php amazon-web-services amazon-ec2 cron