【发布时间】:2020-02-15 08:57:27
【问题描述】:
我想在 EC2 实例上运行 Elastic Search,并在全局范围内访问它。 但是在将其配置更改为
cluster.name: elasticsearch
network.host: XX.XXX.XX.XX
(关联的弹性 IP)
它会抛出一个错误:
原因:java.net.BindException:无法分配请求的地址:绑定
我想它无法绑定到公共 IP 地址
那么
如Elasticsearch cannot start when bind to public ip address 中所述,我尝试将其绑定到0.0.0.0
(我必须添加discovery.seed_hosts: [],因为我运行的是单个实例)。
它在本地运行。
我找不到任何全局访问它的方法。 救命!
我还在入站规则或 EC2 中添加了端口 9200
PS:请在 cmets 中提及任何其他所需信息。
【问题讨论】:
标签: amazon-web-services elasticsearch amazon-ec2