【问题标题】:CORS error when accessing Tomcat inside docker container访问 docker 容器内的 Tomcat 时出现 CORS 错误
【发布时间】:2018-03-19 01:59:51
【问题描述】:

我正在构建一个使用 REST API 与 Camunda 进程交互的 Angular 4 应用程序。尝试登录,遇到 CORS 错误。

Dockerfile:

FROM camunda/camunda-bpm-platform:tomcat-latest

ADD sample.war /camunda/webapps/sample.war

COPY ./web.xml /camunda/webapps/engine-rest/WEB-INF

像这样运行它:

docker build -t camunda-eval .
docker run -d --name camunda -p 8080:8080 <image>

控制台出错:

加载失败 http://localhost:8080/camunda/api/admin/auth/user/default/login/tasklist: 请求中不存在“Access-Control-Allow-Origin”标头 资源。因此不允许使用原点“http://localhost:4200” 访问。

我的 web.xml 看起来像这样:

<web-app version="2.5" xmlns="http://java.sun.com/xml/ns/javaee"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://java.sun.com/xml/ns/javaee    http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd">

  <filter>
    <filter-name>EmptyBodyFilter</filter-name>
    <filter-class>org.camunda.bpm.engine.rest.filter.EmptyBodyFilter</filter-class>
  </filter>
  <filter-mapping>
    <filter-name>EmptyBodyFilter</filter-name>
    <url-pattern>/*</url-pattern>
  </filter-mapping>

  <filter>
    <filter-name>CacheControlFilter</filter-name>
    <filter-class>org.camunda.bpm.engine.rest.filter.CacheControlFilter</filter-class>    
  </filter>
  <filter-mapping>
    <filter-name>CacheControlFilter</filter-name>
    <url-pattern>/*</url-pattern>
  </filter-mapping>

  <!-- Http Basic Authentication Filter -->
  <!-- <filter>
    <filter-name>camunda-auth</filter-name>
    <filter-class>
      org.camunda.bpm.engine.rest.security.auth.ProcessEngineAuthenticationFilter
    </filter-class>
    <init-param>
      <param-name>authentication-provider</param-name>
      <param-value>org.camunda.bpm.engine.rest.security.auth.impl.HttpBasicAuthenticationProvider</param-value>
    </init-param>
    <init-param>
        <param-name>rest-url-pattern-prefix</param-name>
        <param-value></param-value>
      </init-param> 
  </filter>

  <filter-mapping>
    <filter-name>camunda-auth</filter-name>
    <url-pattern>/*</url-pattern>
  </filter-mapping> -->

  <filter>
      <filter-name>Resteasy</filter-name>
      <filter-class>
          org.jboss.resteasy.plugins.server.servlet.FilterDispatcher
      </filter-class>
      <init-param>
          <param-name>javax.ws.rs.Application</param-name>
          <param-value>org.camunda.bpm.engine.rest.impl.application.DefaultApplication</param-value>
      </init-param>
  </filter>

  <filter-mapping>
      <filter-name>Resteasy</filter-name>
      <url-pattern>/*</url-pattern>
  </filter-mapping>
 <filter>
  <filter-name>CorsFilter</filter-name>
  <filter-class>org.apache.catalina.filters.CorsFilter</filter-class>
  <init-param>
    <param-name>cors.allowed.origins</param-name>
    <param-value>*</param-value>
  </init-param>
  <init-param>
    <param-name>cors.allowed.methods</param-name>
    <param-value>GET,POST,HEAD,OPTIONS,PUT</param-value>
  </init-param>
  <init-param>
    <param-name>cors.allowed.headers</param-name>
    <param-value>Content-Type,X-Requested-With,accept,Origin,Access-Control-Request-Method,Access-Control-Request-Headers</param-value>
  </init-param>
  <init-param>
    <param-name>cors.exposed.headers</param-name>
    <param-value>Access-Control-Allow-Origin,Access-Control-Allow-Credentials</param-value>
  </init-param>
  <init-param>
    <param-name>cors.support.credentials</param-name>
    <param-value>true</param-value>
  </init-param>
  <init-param>
    <param-name>cors.preflight.maxage</param-name>
    <param-value>10</param-value>
  </init-param>
</filter>
  <filter-mapping>
    <filter-name>CorsFilter</filter-name>
    <url-pattern>/*</url-pattern>
  </filter-mapping>
</web-app>

关于如何解决这个问题的任何想法?

【问题讨论】:

    标签: tomcat docker cors camunda


    【解决方案1】:

    您收到此错误是因为“localhost:4200”和“localhost:8080”在涉及 CORS 时不是同一台机器。

    一般来说,您有 3 种方法可以避免这种情况:

    1. 只需告诉您的浏览器忽略 CORS(例如 chromium-browser --disable-web-security --user-data-dir) - 如果您只是想玩玩,这是最快的,但当然没有生产解决方案
    2. 在 8080 上设置 CORS 标头以允许从 4200 访问...此处不适用(很容易,因为您不控制 camunda-app)
    3. 使用通过反向代理在内部重新路由请求的“边缘”(或“网关”)服务器。含义:您的浏览器只与网关(比如说端口 80)对话,这会将请求路由到您的任务列表(4200)或 camunda(8080)。这是解决这个问题的标准方法,如果你寻找 nginx 或 zuul,你会找到很好的文档。不过,它将需要一个额外的服务组件。

    【讨论】:

      猜你喜欢
      • 2019-10-08
      • 2017-09-23
      • 1970-01-01
      • 1970-01-01
      • 2019-12-04
      • 2017-04-24
      • 2019-06-28
      • 2021-10-30
      • 1970-01-01
      相关资源
      最近更新 更多