【问题标题】:deploying a grails war file to a Tomcat server将 grails war 文件部署到 Tomcat 服务器
【发布时间】:2012-08-10 01:27:55
【问题描述】:

我编写了一个Grails 应用程序,一切正常,然后我生成了myapp.war 文件以部署在VM 中运行的Tomcat 6.0 服务器中。我用

生成了.war文件
grails war

然后我将文件移动到服务器上的/tomcat/webapp 位置,并将其扩展至目录myapp。 但是,当我尝试访问该应用程序时,我得到:

Message:    
FAIL - Application at context path /myapp could not be started

我不熟悉将 .war 文件部署到 Tomcat 服务器。我在SpringSource IDE 中测试我的应用程序,就像localhost:8080/myapp 一样,一切正常,但是,当我尝试将其部署到<my-server>:8080/myapp 时,我收到了该错误消息。 有这种情况吗?有人可以帮我解决这个错误吗?

【问题讨论】:

  • 查看日志并提供更多信息
  • 也许您的 grails.serverURL 没有在 Config.groovy 中正确设置?它必须设置为生产环境中生产服务器的 URL(包括上下文路径)。默认情况下,Grails 在生产环境中打包 WAR。
  • @ArtHanzel 我今晚会发布更多细节!

标签: tomcat grails groovy


【解决方案1】:

检查 Tomcat 中的日志文件。仔细检查每一行以检查致命错误。可能是日志文件中的一行导致 Tomcat 拒绝启动应用程序。

我遇到过几种情况,其中日志文件中的一个小的“无辜”行是根本原因。

【讨论】:

    【解决方案2】:

    仅供参考,被引用的日志文件位于 %TOMCAT_HOME%/logs 下。

    另一种选择是使用 Tomcat 管理器。这是一个关于如何开始的好链接。 https://tomcat.apache.org/tomcat-7.0-doc/manager-howto.html

    无论哪种方式,当您单击部署按钮(附图片)时,如果您的战争部署发生了关键问题,它将给您一个错误。它当然没有 catalina 日志或 stdio 日志那么详细,但它可能更容易排除故障,更不用说您不必手动继续传输文件。

    【讨论】:

      猜你喜欢
      • 2018-07-25
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2015-12-10
      • 2012-10-29
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      相关资源
      最近更新 更多