【问题标题】:WildFly 10.1.0.Final | Loading page during deployment | default-response-code is ignoredWildFly 10.1.0.Final |部署期间加载页面 |默认响应代码被忽略
【发布时间】:2017-07-14 00:13:04
【问题描述】:

我想区分“部署挂起”和“部署失败”并分别显示加载或错误页面。因此,我尝试在 undertow 配置中设置值 default-response-code。

<host name="default-host" alias="localhost" default-response-code="503">

但是当我启动服务器时,在部署过程中访问我的部署地址时仍然收到 404。

我是否遗漏了什么,或者在部署过程中是否有更好的方法来显示加载页面?

【问题讨论】:

    标签: deployment wildfly http-status-codes undertow


    【解决方案1】:

    我通过添加一个自定义的 Undertow HttpHandler 作为 WildFly 模块解决了这个问题。在我的 WildFly 配置中将此处理程序添加为过滤器后,它会返回 HTTP 状态代码 503,直到成功部署部署单元。

    我按照这个例子做了一些修改: https://github.com/thomasdarimont/undertow-extensions

    【讨论】:

      【解决方案2】:

      可以按照http://lists.jboss.org/pipermail/undertow-dev/2017-January/001861.html 的建议解决 503 无法覆盖 404 的问题,该建议建议删除欢迎内容过滤器。这确实解决了这个问题。然而,如何自定义 503 页面仍然是一个问题,因为 503 - Service Unavailable 不是一个非常用户友好的消息。

      【讨论】:

        猜你喜欢
        • 2023-01-18
        • 2018-02-09
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 1970-01-01
        • 2017-07-13
        • 2018-09-08
        • 2014-11-17
        相关资源
        最近更新 更多