【问题标题】:How to install Web Tools Platform (WTP) 3.9.5 on Eclipse Oxygen.3a (4.7.3a) on Windows 10, so I can use Tomcat 9 + Java 10?如何在 Windows 10 上的 Eclipse Oxygen.3a (4.7.3a) 上安装 Web Tools Platform (WTP) 3.9.5,以便我可以使用 Tomcat 9 + Java 10?
【发布时间】:2018-11-23 05:48:36
【问题描述】:

我正在尝试从 Eclipse for Java EE zip 文件中获取 Eclipse Oxygen.3a(截至今天的最新版本,4.7.3a,x64;即 eclipse-jee-oxygen-3a-win32-x86_64.zip, 350,098,461 字节)与 Java 10(JDK 和 JRE 10.0.1,x64)和 Tomcat 9(9.0.8,x64)的组合一起使用。这是在 Windows 10 企业版上。

一切顺利,直到我尝试从 Eclipse 中启动 Tomcat 服务器,此时我在控制台选项卡中收到以下错误消息:

-Djava.endorsed.dirs=C:\Program Files\Apache Software Foundation\Tomcat 9.0\endorsed 不受支持。认可的标准和独立 API 模块化形式将通过可升级模块的概念得到支持。

这看起来与apache tomcat 9.x not working with eclipse & Java 10.0.1 中的错误完全相同。

根据Eclipse bug 533162,我需要a patched WTP 3.9.4 或3.9.5.RC1 or newer。 3.9.5 was released on April 16.

但是,这就是问题的关键; the answer to that previous question 表示我应该在http://download.eclipse.org/webtools/repository/oxygen/ 添加Eclipse 存储库,然后检查更新。不管我做什么,我似乎找不到任何比 3.9.4 更新的 WTP 版本,而且 3.9.4 对我不起作用(正如预期的那样,鉴于 Eclipse 错误报告)。在 Help > Install new software... 下,选择如下选项

  • 仅显示可用软件的最新版本 - 未选中
  • 按类别对项目进行分组 - 选中
  • 仅显示适用于目标环境的软件 - 未选中
  • 在安装过程中联系所有更新站点以查找所需的软件 - 已检查
  • 隐藏已安装的项目 - 未选中

...我只获得“Web 工具平台 (WTP)”和“Web 工具平台 SDK (WTP SDK)”版本 3.9.0、3.9.1、3.9.1a、3.9.3 和 3.9.4。任何地方都没有3.9.5!此外,this answer here 表示 3.9.5 确实应该可用。

如果我展开“Web Tools Platform (WTP) 3.9.4”节点,则在 3.9.2.v201803221834 版本中有一个“Eclipse Web Developer Tools”条目。

如果我在“已安装的内容”下查看,这将打开 Eclipse 安装详细信息窗口,其中选择了安装历史选项卡并在“以前的配置”下选择了“当前安装”,则有一个“Eclipse Web 开发人员工具”条目" 在 3.9.2.v201804042202 版本中,它看起来早于 2018-04-16。

如果我选择帮助 > 检查更新,它会返回从“Eclipse JSON 编辑器和工具”(我没有立即需要)到版本 3.8.0.v201601291607 的更新建议和“无法完成”的错误由于依赖项冲突而安装。”和“未找到补救措施”。

令人讨厌的是,Tomcat 9 Windows 服务指向 Java 10 运行时并通过 services.msc 正常启动,但随后我失去了 Eclipse 集成,需要作为单独的步骤构建并发布到 Web 服务器(更类似于如何部署到非开发环境)。

我缺少什么能够安装 WTP 3.9.5,以便我可以针对 Tomcat 9 和 Java 10 进行开发并从 Eclipse 中发布?

为了完整起见,将 Eclipse JSON 编辑器和工具 更新到版本 3.8.0.v201601291607 失败,因为(每行开头的句点保留缩进;原始版本是 2 的倍数空格):

由于依赖项冲突,无法完成安装。
..正在安装的软件:Eclipse JSON 编辑器和工具 3.8.0.v201601291607 (org.eclipse.wst.json_ui.feature.feature.group 3.8.0.v201601291607)
..当前安装的软件:Eclipse Web Developer Tools 3.9.2.v201804042202 (org.eclipse.wst.web_ui.feature.feature.group 3.9.2.v201804042202)
..一次只能安装以下之一:
....Eclipse JSON 编辑器和工具 1.0.0.v201512211354 (org.eclipse.wst.json.ui 1.0.0.v201512211354)
....Eclipse JSON 编辑器和工具 1.0.1.v201608312053 (org.eclipse.wst.json.ui 1.0.1.v201608312053)
....Eclipse JSON 编辑器和工具 1.0.100.v201612232120 (org.eclipse.wst.json.ui 1.0.100.v201612232120)
....Eclipse JSON 编辑器和工具 1.0.0.v201603042101 (org.eclipse.wst.json.ui 1.0.0.v201603042101)
....Eclipse JSON 编辑器和工具 1.0.0.v201604280217 (org.eclipse.wst.json.ui 1.0.0.v201604280217)
....Eclipse JSON 编辑器和工具 1.0.0.v201605251755 (org.eclipse.wst.json.ui 1.0.0.v201605251755)
..不能满足依赖:
....来自:Eclipse JSON 编辑器和工具 1.1.2.v201711071522 (org.eclipse.wst.json_ui.feature.feature.group 1.1.2.v201711071522)
....收件人:org.eclipse.wst.json.ui [1.0.100.v201612232120]
..不能满足依赖:
....来自:Eclipse JSON 编辑器和工具 3.8.0.v201601291607 (org.eclipse.wst.json_ui.feature.feature.group 3.8.0.v201601291607)
....收件人:org.eclipse.wst.json.ui [1.0.0.v201512211354]
..不能满足依赖:
....来自:Eclipse Web Developer Tools 3.9.2.v201804042202 (org.eclipse.wst.web_ui.feature.feature.group 3.9.2.v201804042202)
....收件人:org.eclipse.wst.json_ui.feature.feature.group [1.1.2.v201711071522]

【问题讨论】:

  • 您是从 Java EE IDE zip 开始的吗?哪一个?
  • 作为一种解决方法,因为这是 Oxygen.3a 之后的版本,您应该能够从 download.eclipse.org/webtools/downloads/drops/R3.9.5/… 下载 3.9.5 更新站点 zip 存档并直接使用它。
  • @nitind 查看编辑。
  • 至于那个解决方法的建议,我一定遗漏了一些完全明显的东西,因为我看不到我应该从那里下载什么,以及如何处理它。如果您愿意通过一些分步描述将其转化为实际答案,我很可能会接受。
  • 您当前的安装有问题。您是否在现有的拉链上打开了这个拉链?您是否设置并启用了比 Oxygen 更早的更新站点?

标签: eclipse


【解决方案1】:

我缺少什么能够安装 WTP 3.9.5,这样我就可以 针对 Tomcat 9 和 Java 10 进行开发并从 Eclipse 中发布?

我认为您没有遗漏任何内容,因为 Eclipse 似乎已经悄悄撤回了 WTP 3.9.5 版:

抱歉,除非 3.10.0 版适合您,否则我找不到太多好消息。我无法尝试。

【讨论】:

  • 这听起来很有希望。下周我可能有机会尝试一下,并会回复您是否有效。在此,谢谢!
  • @MichaelKjörling 我更新了我的帖子以表明 WTP 3.10.0 仅适用于 Photon。底线是(像你一样)我无法让 Tomcat 9.x 在使用 Java 10 的 Eclipse 中工作,即使其他人似乎已经管理了它。
  • 很难找到仍然有效的链接,但download.eclipse.org/webtools/downloads/drops/R3.9.5/… 做到了
  • @Jacob 感谢您的反馈。我想在我回答时 3.9.5 出现了故障。需要明确的是,如果您使用的是 3.9.5,那么您使用的是 Oxygen,对吗?见What version of Eclipse does WTP work with?。
  • @skomisa 是的,我可能应该切换到 3.10,但因为我遇到了其他故障
猜你喜欢
  • 1970-01-01
  • 1970-01-01
  • 2021-02-16
  • 1970-01-01
  • 2018-10-10
  • 2019-07-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
相关资源
最近更新 更多