【发布时间】:2018-01-09 18:07:30
【问题描述】:
我将 ElasticSearch-5.2.1 与 springboot 一起使用,并且在 elasticsearch.bat 中出现错误
java.lang.IllegalStateException:收到来自不受支持版本的消息:[2.0.0] 最低兼容版本为:[5.0.0]
在我的应用程序控制台中出现以下错误:
原因:org.elasticsearch.client.transport.NoNodeAvailableException:配置的节点都不可用:[{#transport#-1}{127.0.0.1}{127.0.0.1:9300}]
当我在谷歌搜索时,它要求升级传输客户端,但我如何将传输客户端从 2.0 升级到 5.0
下面是我的配置代码:
@Value("${elasticsearch.port}")
private int EsPort;
@Value("${elasticsearch.clustername}")
private String EsClusterName;
@Value("${elasticsearch.host}") 私有字符串 EsHost;
@Bean
public Client client() throws Exception {
Settings esSettings = Settings.settingsBuilder().put("cluster.name", EsClusterName).build();
return TransportClient.builder()
.settings(esSettings)
.build()
.addTransportAddress(new InetSocketTransportAddress(InetAddress.getByName(EsHost), EsPort));
}
@Bean
public ElasticsearchOperations elasticsearchTemplate() throws Exception {
return new ElasticsearchTemplate(client());
}
【问题讨论】: