【发布时间】:2015-11-19 04:30:34
【问题描述】:
我有一个在 IIS 7.5 下运行的 ASP.NET 网站,效果很好。
现在我们正在试验一台运行 IIS 10 的新 Windows 10 服务器。将相同的网站复制到新服务器并尝试打开它:
HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid.
...
Error Code 0x8007000d
...
Config Source:
-1:
0:
我looked up错误码:
原因:出现此问题的原因是 ApplicationHost.config 文件或 Web.config 文件包含格式错误的 XML 元素。
解决方案:从 ApplicationHost.config 文件或 Web.config 文件中删除格式错误的 XML 元素。
但是那个 web.config 文件已经工作了很多年了。什么也没有变。所以我认为“格式错误的 xml”消息是一条红鲱鱼,我肯定还缺少其他一些设置。
有什么想法吗?
【问题讨论】:
-
我遇到了同样的问题 - 但还没有找到解决办法
标签: asp.net xml iis-7.5 iis-10