【问题标题】:web.config that worked under IIS 7.5 doesn't work under IIS 10在 IIS 7.5 下工作的 web.config 在 IIS 10 下不起作用
【发布时间】:2015-11-19 04:30:34
【问题描述】:

我有一个在 IIS 7.5 下运行的 ASP.NET 网站,效果很好。

现在我们正在试验一台运行 IIS 10 的新 Windows 10 服务器。将相同的网站复制到新服务器并尝试打开它:

HTTP Error 500.19 - Internal Server Error

The requested page cannot be accessed because the related configuration data for the page is invalid.
...
Error Code     0x8007000d
...
Config Source:
  -1: 
   0: 

我looked up错误码:

原因:出现此问题的原因是 ApplicationHost.config 文件或 Web.config 文件包含格式错误的 XML 元素。

解决方案:从 ApplicationHost.config 文件或 Web.config 文件中删除格式错误的 XML 元素。

但是那个 web.config 文件已经工作了很多年了。什么也没有变。所以我认为“格式错误的 xml”消息是一条红鲱鱼,我肯定还缺少其他一些设置。

有什么想法吗?

【问题讨论】:

  • 我遇到了同样的问题 - 但还没有找到解决办法

标签: asp.net xml iis-7.5 iis-10


【解决方案1】:

我遇到了完全相同的问题,对我来说这是因为我忘记为 IIS 安装 Url Rewrite 2.0,所以我的重写规则导致了错误。不知道这对你来说是否一样。

我通过注释掉 web.config 的块来解决这个问题,直到我让它停止抛出该错误。

希望有帮助!

【讨论】:

  • 是的,URL 重写是罪魁祸首。谢谢!
  • 耶!也为我解决了这个问题!
  • 我安装了 URL Rewrite 2.1,仍然出现同样的错误 =(
  • 你是英雄,这是我从 IIS 8 到 IIS 10 服务器的问题
猜你喜欢
  • 1970-01-01
  • 2012-08-05
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 2023-03-08
  • 1970-01-01
  • 2013-07-26
相关资源
最近更新 更多