【发布时间】:2016-07-23 15:13:12
【问题描述】:
我想在运行 express js 服务器时永远使用。通常我用 npm start 启动我的服务器,但是我如何永远启动 express js 服务器。如果我使用 node forever app.js 命令,服务器是还没开始。我是 node 和 express 的新手。请帮帮我。提前致谢。
在给永远启动 ./bin/www 命令之后。我得到了
C:\Users\Gourab>forever start ./bin/www
warn: --minUptime not set. Defaulting to: 1000ms
warn: --spinSleepTime not set. Your script will exit if it does not stay up f
or at least 1000ms
info: Forever processing file: ./bin/www
error: Cannot start forever
error: script C:\Users\Gourab\bin\www does not exist.
【问题讨论】:
-
在你的 package.json 文件中,'start' 脚本中的命令是什么?
-
命令是“node ./bin/www”@war1oc
-
在哪个文件中以及如何设置 spinSleepTime 和 minUptime ????