【问题标题】:How to use forever while running the express js server如何在运行 express js 服务器时永远使用
【发布时间】:2016-07-23 15:13:12
【问题描述】:

我想在运行 express js 服务器时永远使用。通常我用 npm start 启动我的服务器,但是我如何永远启动 express js 服务器。如果我使用 node forever app.js 命令,服务器是还没开始。我是 node 和 express 的新手。请帮帮我。提前致谢。

在给永远启动 ./bin/www 命令之后。我得到了

C:\Users\Gourab>forever start ./bin/www
warn:    --minUptime not set. Defaulting to: 1000ms
warn:    --spinSleepTime not set. Your script will exit if it does not stay up f
or at least 1000ms
info:    Forever processing file: ./bin/www
error:   Cannot start forever
error:   script C:\Users\Gourab\bin\www does not exist.

【问题讨论】:

  • 在你的 package.json 文件中,'start' 脚本中的命令是什么?
  • 命令是“node ./bin/www”@war1oc
  • 在哪个文件中以及如何设置 spinSleepTime 和 minUptime ????

标签: node.js express forever


【解决方案1】:
forever start ./bin/www

这是您启动服务器所需运行的命令。 您的 package.json 文件应包含:

"scripts": {
    "start": "node ./bin/www"
},

您可以使用以下命令设置 minUptime 和 spinSleepTime:

forever start --minUptime 1000 --spinSleepTime 1000 ./bin/www

【讨论】:

  • 我添加了给出这个命令后出现的错误@war1oc
  • 你必须从你的项目根目录运行命令,其中 package.json 文件是
  • -w 表示它将监视文件更改,很高兴您的问题得到解决。如果它有效,你能接受答案吗:)
猜你喜欢
  • 2014-10-11
  • 1970-01-01
  • 1970-01-01
  • 2020-11-08
  • 2017-04-03
  • 1970-01-01
  • 1970-01-01
  • 1970-01-01
  • 2014-12-02
相关资源
最近更新 更多