【问题标题】:Unable to connect to Oracle database using instance_name无法使用 instance_name 连接到 Oracle 数据库
【发布时间】:2020-01-02 01:09:20
【问题描述】:

我可以通过在连接字符串中使用 service_name 而不是使用实例名称来连接到数据库。当我使用 instance_name 时,出现以下错误。

ORA-12514: TNS:listener 目前不知道连接描述符中请求的服务

当我在设置 ORACLE_SID 后尝试从主机连接到数据库时,它没有连接

[oracle@OfflineRep ~]$ sqlplus / as sysdba

SQL*Plus: Release 11.2.0.1.0 Production on Wed Aug 28 15:25:22 2019

Copyright (c) 1982, 2009, Oracle.  All rights reserved.

Connected to an idle instance.

但是当我故意使用 SID 时连接

[oracle@OfflineRep ~]$ sqlplus sys/***************@sid as sysdba

SQL*Plus: Release 11.2.0.1.0 Production on Wed Aug 28 15:26:05 2019

Copyright (c) 1982, 2009, Oracle.  All rights reserved.


Connected to:
Oracle Database 11g Release 11.2.0.4.0 - 64bit Production

【问题讨论】:

    标签: database oracle


    【解决方案1】:

    您似乎正在尝试使用 sqlplus / as sysdba 从 11.2.0.1.0 Oracle 主目录连接,但数据库位于 11.2.0.4.0 主目录上。您可能需要将 ORACLE_HOME 变量设置为指向数据库使用的 Oracle 主目录,并在将 ORACLE_HOME 设置为数据库的 11.2.0.4.0 主目录后将 $ORACLE_HOME/bin 放入您的路径中。

    【讨论】:

      猜你喜欢
      • 2019-10-18
      • 2019-05-20
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2019-08-25
      • 2012-08-11
      • 2016-08-29
      相关资源
      最近更新 更多