【问题标题】:Websphere CE issue in Eclipse EEEclipse EE 中的 Websphere CE 问题
【发布时间】:2011-01-28 06:11:02
【问题描述】:

我已经下载了 Websphere 2.1 App Server 并验证它可以正常工作。我现在想通过将服务器添加到服务器选项卡来使用 Eclipse EE 来管理它。完成设置时一切似乎都正常,但是当我启动服务器时,我收到错误消息:

ERROR [GBeanInstanceState] 启动时出错; GBean 现在处于 FAILED 状态: abstractName="org.apache.geronimo.framework/j2ee-system/2.1.4/car?ServiceModule=org.apache.geronimo.framework/j2ee-system/2.1.4/car,j2eeType =AttributeStore,名称=AttributeManager" java.io.IOException:无法将可管理的属性文件写入目录 /opt/IBM/WebSphere/AppServerCommunityEdition/var/config 在 org.apache.geronimo.system.configuration.LocalAttributeManager.ensureParentDirectory(LocalAttributeManager.java:573) 在 org.apache.geronimo.system.configuration.LocalAttributeManager.load(LocalAttributeManager.java:327) ....

我想知道是否有人遇到过这个特定问题?

【问题讨论】:

  • 问题自我解决:似乎 java IOException 仅仅是因为 Eclipse 没有正确的权限写入 config/ 目录。一个简单的 sudo eclipse 就足够了。
  • 回答您自己的问题并将您的答案标记为最佳 :)
  • @medopal - 你会如何回答你自己的问题?
  • 使用下面的回答框,从您的评论中添加答案,您可以稍后选择它作为最佳答案
  • @medopal 感谢您的帮助

标签: java eclipse jakarta-ee


【解决方案1】:

问题自我解决:似乎 java IOException 仅仅是因为 Eclipse 没有正确的权限来写入 config/ 目录。一个简单的 sudo eclipse 就足够了。

【讨论】:

    猜你喜欢
    • 2015-08-20
    • 1970-01-01
    • 1970-01-01
    • 2015-08-06
    • 1970-01-01
    • 1970-01-01
    • 2013-08-07
    • 1970-01-01
    • 1970-01-01
    相关资源
    最近更新 更多