【发布时间】:2013-07-31 01:26:20
【问题描述】:
在我的 Wordpress 安装中,自从更新到最新版本 3.5.2 后,我目前无法添加新帖子。点击 Post > Add New 显示以下错误:
Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 491520 bytes) in /var/www/www.mysite.com/wp-admin/edit-form-advanced.php on line 306
出于测试目的,我在禁用所有插件的情况下运行了默认模板(21 个)。
我已将 php.ini、wp-config.php 和 default-constants.php 中的内存增加到 512M,但我似乎仍然无法克服这个错误(这似乎只显示了256M)。
仅供参考....数据库不是新的 - 它有超过一千个帖子。此问题仅发生在某些管理员用户身上,其他人可以看到 发布 > 添加新 屏幕,但仍会在管理区域的其他页面上看到内存问题。
任何帮助将不胜感激。谢谢!
【问题讨论】:
-
您是否编辑了正确的
php.ini?你用的是 Apache 还是 fast-cgi,还是 suhosin 补丁? -
使用 nginx... 我确定我编辑了正确的 php.ini 只是因为在使用 php_info() 重新启动后确认并且它显示正确分配了 512MB。不过谢谢……这是我反复检查的事情。
-
只是检查。你确实重启了 nginx 和 fast_cgi 服务吧?
-
另外,由于您使用的是 nginx,您是否也会碰巧使用 php-fpm 包装器?如果是这样,它是否在套接字上运行,如果是这样,(几乎在那里)你可以发布资源分配配置
-
使用“/etc/init.d/nginx restart”,nginx正常重启。认为它重新启动正确,因为 php_info() 更新了我在 php.ini 中所做的更改。不过我没有重启 fast_cgi……有必要吗?