【问题标题】:Elastic BeanStalk loading configuration from another region failed来自另一个区域的 Elastic BeanStalk 加载配置失败
【发布时间】:2020-05-14 16:52:37
【问题描述】:

我已将某个区域的 BeanStalk 应用程序中保存的配置文件上传到另一个区域的另一个 BeanStalk 应用程序。 加载该配置时出现错误

名为“awseb-e-sme7w3eym3-stack”的堆栈已中止操作。当前的 状态:'CREATE_FAILED' 原因:以下资源未能 创建:[AWSEBLoadBalancer]

创建负载均衡器失败原因:属性监听器不能 空关于这个问题的任何想法?

查看配置文件

AWSConfigurationTemplateVersion: 1.1.0.0
EnvironmentConfigurationMetadata:
  DateCreated: '1580272974000'
  DateModified: '1580273310143'
  Description: xxxxxxxxxxxxxxxxxxxxx
EnvironmentTier:
  Name: WebServer
  Type: Standard
OptionSettings:
  AWSEBAutoScalingGroup.aws:autoscaling:updatepolicy:rollingupdate:
    MaxBatchSize: '1'
    MinInstancesInService: '1'
    RollingUpdateEnabled: true
    RollingUpdateType: Health
  AWSEBAutoScalingLaunchConfiguration.aws:autoscaling:launchconfiguration:
    EC2KeyName: xxxxxxxxxxxxxxxxxxx
  AWSEBCloudwatchAlarmHigh.aws:autoscaling:trigger:
    UpperThreshold: '60'
  AWSEBCloudwatchAlarmLow.aws:autoscaling:trigger:
    BreachDuration: '2'
    LowerThreshold: '25'
    MeasureName: CPUUtilization
    Period: '1'
    Statistic: Maximum
    Unit: Percent
  AWSEBLoadBalancerSecurityGroup.aws:ec2:vpc:
    VPCId: vpc-xxxxxxxxxxxxxxxx
  AWSEBV2LoadBalancerListener.aws:elbv2:listener:default:
    ListenerEnabled: false
  AWSEBV2LoadBalancerListener443.aws:elbv2:listener:443:
    SSLCertificateArns: arn:aws:acm:us-east-2:xxxxxxxxxxx:certificate/xxxxxxx-xxxxx-xxxx-xxxx-xxxxxxxxxxxx
  AWSEBV2LoadBalancerTargetGroup.aws:elasticbeanstalk:environment:process:default:
    HealthCheckPath: /rest/account/ping
    MatcherHTTPCode: '200'
    Port: '80'
    Protocol: HTTP
  aws:autoscaling:launchconfiguration:
    IamInstanceProfile: aws-elasticbeanstalk-ec2-role
    SecurityGroups:
    - sg-xxxxxxxxxxxxx
  aws:ec2:instances:
    InstanceTypes: t2.small
  aws:ec2:vpc:
    ELBSubnets: subnet-xxxxxxxxxxxxxxxxxx,subnet-xxxxxxxxxxxxxxxxxx,subnet-xxxxxxxxxxxxxxx
    Subnets: subnet-xxxxxxxxxxxxxxxxx,subnet-xxxxxxxxxxxxxxxxx,subnet-xxxxxxxxxxxxxxxxx
  aws:elasticbeanstalk:application:environment:
    JDBC_CONNECTION_STRING: jdbc:mysql://xxxxxxxxxxxxxxxxxxxxxxxxxxxx?user=xxxxxxxx&password=xxxxxxxxxxx&rewriteBatchedStatements=true&characterEncoding=UTF-8
    aws.accessKeyId: xxxxxxxxxxxxxxxxxx
    aws.secretKey: xxxxxxxxxxxxxxxxxxxx
    com.aws.secretManger.secret.name: xxxxxxxxxxxxxxx
    com.aws.secretManger.secret.region: us-east-2
    com.decsond.loggly.token: xxxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxx@xxxxx
    com.decsond.metakey: xxxxxxxxxxxxxxxxx/XXX==
    com.decsond.mode: debug
    com.decsond.server.db.environment: aws
    com.decsond.server.dpBinaryColumn: xxxxxxxxxxxx
    com.decsond.server.environment: xxxxxxxxxx
    com.decsond.server.type: pms
  aws:elasticbeanstalk:container:tomcat:jvmoptions:
    JVM Options: -XX:+CMSClassUnloadingEnabled -Dmvel.disable.jit=true -Ddrools.permgenThreshold=0
    Xms: 512m
    Xmx: 1024m
  aws:elasticbeanstalk:environment:
    LoadBalancerType: application
    ServiceRole: arn:aws:iam::xxxxxxxxxxxxxx:role/aws-elasticbeanstalk-service-role
  aws:elasticbeanstalk:healthreporting:system:
    SystemType: enhanced
  aws:elasticbeanstalk:managedactions:
    ManagedActionsEnabled: true
    PreferredStartTime: SAT:03:01
  aws:elasticbeanstalk:managedactions:platformupdate:
    InstanceRefreshEnabled: true
    UpdateLevel: minor
  aws:elasticbeanstalk:xray:
    XRayEnabled: true
  aws:elbv2:listener:443:
    DefaultProcess: default
    ListenerEnabled: true
    Protocol: HTTPS
    Rules: ''
    SSLPolicy: ELBSecurityPolicy-2016-08
Platform:
  PlatformArn: arn:aws:elasticbeanstalk:us-east-2::platform/Tomcat 8.5 with Java 8
    running on 64bit Amazon Linux/3.3.1

对这个问题有任何想法吗?

【问题讨论】:

    标签: java amazon-web-services amazon-elastic-beanstalk


    【解决方案1】:

    最可能的原因是您引用了保存配置的区域中的对象。

    这是新区的第一个EB应用/环境吗?

    如果是这样,首先创建一个测试应用程序和环境是值得的,使用您想要的功能......这将使 EB 有机会创建它所依赖的所有特定区域的幕后魔法。

    【讨论】:

      猜你喜欢
      • 2017-02-17
      • 1970-01-01
      • 1970-01-01
      • 2017-08-03
      • 2016-10-23
      • 2021-08-15
      • 2016-08-31
      • 2018-08-27
      • 2020-05-09
      相关资源
      最近更新 更多