【问题标题】:Can not connect remotely to a second instance of SQL Server 2016无法远程连接到 SQL Server 2016 的第二个实例
【发布时间】:2018-09-19 05:18:53
【问题描述】:

在服务器中,我有 2 个实例,第一个是默认的,在 TCP 端口 1433 上称为 SQLCompart,第二个在 TCP 端口 1435 上称为 AISLANTES。

当我尝试远程连接到 SQLCOMPART 时,它可以成功运行,但只是使用 ip(它不与命名实例 <IP>\<INSTANCE> 连接)。

所以这里的问题是我无法远程连接到AISLANTES。

我正在尝试使用 <IP>, <PORT> 以及 <IP>\<INSTANCE> 和 <IP>\<INSTANCE>, <PORT>

tcp 端口 1435 的防火墙入站规则已启用。

我错过了什么?

SQL Server 配置管理器

SQL Server 配置管理器 TCP/IP 属性

这是我得到的错误 SQL SERVER MANAGEMENT STUDIO SQLCMD

【问题讨论】:

  • 你用什么连接?向我们展示一个有效的和一个无效的实际连接字符串或文本。还有您正在连接的工具和/或代码。最后,您收到什么错误消息?
  • 我使用错误图像编辑帖子,我正在使用 SQL Server Management Studio,还尝试使用带有命令行的 sqlcmd
  • 请编辑您的图片以隐藏您的密码。

标签: sql-server sql-server-2016


【解决方案1】:

可能的原因:

  • 端口已更改,但实例未重新启动
  • 多个防火墙和端口 1435 未在所有防火墙上打开
  • 根本未启用第二个实例的 TCP

考虑检查您最新的 SQL Server 日志并找到类似的内容:

2018-04-09 18:53:11.95 spid11s     Server local connection provider is ready to accept connection on [ \\.\pipe\SQLLocal\MSSQLSERVER ].
2018-04-09 18:53:11.95 spid11s     Server local connection provider is ready to accept connection on [ \\.\pipe\sql\query ].
2018-04-09 18:53:11.97 Server      Server is listening on [ ::1 <ipv6> 1434].
2018-04-09 18:53:11.97 Server      Server is listening on [ 127.0.0.1 <ipv4> 1434].

这样您就可以确定 SQL Server 在哪个端口上侦听传入连接

附言如果 SQL 实例安装在域控制器上,它不能使用 NETWORK_SERVICE 作为帐户

【讨论】:

    猜你喜欢
    • 1970-01-01
    • 2011-10-22
    • 2015-07-03
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 1970-01-01
    • 2016-06-16
    相关资源
    最近更新 更多