【问题标题】:Arch Linux Apache2 500 server error htaccessArch Linux Apache2 500 服务器错误 htaccess
【发布时间】:2017-10-17 22:05:04
【问题描述】:

我正在一个小组中开展一个项目。我是唯一一个使用 Linux 的人。无论如何,我们使用 git 并且有一个文件给我带来了问题。

htaccess 包含以下内容:

<IfModule authz_core_module>
    Require all granted
</IfModule>

如果我注释掉 Require all granted,它可以工作,但是,当它没有被注释掉时,它会给我一个 500 服务器错误。

我确实有authz_core_module,但我无法禁用它,因为如果它不是模块,它将Deny from all。

为什么那行给我一个 500 服务器错误?该文件适用于所有其他使用 Windows 的人。是不是因为我的 Linux apache?

【问题讨论】:

    标签: .htaccess


    【解决方案1】:

    我通过将这两行添加到我的 httpd.conf 文件中来让它工作:

    <Directory /THEPATHHERE/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride FileInfo Indexes Authconfig
    </Directory>
    

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 2016-08-31
      • 2011-08-08
      • 2015-09-30
      • 1970-01-01
      • 2023-02-23
      • 2016-09-22
      • 2017-04-05
      • 1970-01-01
      相关资源
      最近更新 更多