【问题标题】:XAMPP doesn't work after update to macOS Big Sur更新到 macOS Big Sur 后 XAMPP 不起作用
【发布时间】:2021-02-26 06:51:46
【问题描述】:

今天我将我的 mac 更新为 macOS Big Sur,但我无法打开 XAMPP。当我点击应用程序时,它没有给出任何响应。

你知道如何解决这个问题吗?

【问题讨论】:

    标签: macos xampp macos-big-sur


    【解决方案1】:

    您可以进行全新安装,但您会丢失所有旧文件和数据库。我建议对这些数据进行备份。

    卸载旧版本的 xampp。

    通过 brew 安装 Xampp

    brew install --cask xampp
    

    如果你没有安装 brew

    /bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/HEAD/install.sh)"
    

    HomeBrew

    【讨论】:

      【解决方案2】:

      如果您收到错误消息:

      无法计算 MAC 地址:使用 fd 10 进行 I/O 通知 hv_vm_create HV_ERROR(未指定错误)

      您需要从 bitnami 下载新的 hyperkit 并替换当前的

      cd /tmp
      
      curl -LJO "https://downloads.bitnami.com/files/hyperkit/hyperkit-testing-`20210430"`
      
      mv /tmp/hyperkit-testing-20210430 ~/.bitnami/stackman/helpers/hyperkit
      
      chmod +x ~/.bitnami/stackman/helpers/hyperkit
      

      在此处阅读教程: https://floyk.com/en/post/xampp-doesnt-work-after-update-to-macos-big-sur

      【讨论】:

        【解决方案3】:

        我有 Xampp 7.4.9 并将 Mac OS 更新到 Big Sur。 Xampp 不想在那之后推出。我无法访问隐藏在虚拟机路径结构中某处的 /htdocs 文件夹中的所有项目。 请注意,我使用的是 7.4.9-VM 版本(不是 7.4.9-Installer),这就是为什么我的所有文件都被阻止在 /Users/'your_user_name'/.bitnami/stackman/machines/xampp/vm/machine.qcow2 实际上所有文件在这里都很重要: /Users/'your_user_name'/.bitnami/stackman/machines/xampp 不仅是 machine.qcow2

        我的解决方案是前面提到的解决方案的混合,因为它们没有完全帮助。

        1. 首先进行备份 - 将旧结构(包含被阻止的文件)复制到某个目录 - 所有这些结构: /Users/'your_user_name'/.bitnami/stackman/machines/xampp (要在 MacOS 中查看隐藏文件,请使用 [Command]+[Shift]+[.]) 你也可以重命名 /Users/'your_user_name'/.bitnami/ 类似于 /Users/'your_user_name'/.my_blocked_files_bitnami/

        2. 由于这里的程序员建议安装 7.4.12-VM,我安装了这个版本。安装“虚拟机”版本非常重要(如您所见,每个 Xampp 版本都有 2 个安装程序)

        3. 在我启动 7.4.12-VM 后,新目录在此处创建: /Users/'your_user_name'/.bitnami/ Xampp 将正常工作,但没有您的旧项目。

        4. 不要执行此步骤:因为这里的程序员建议只更改一个文件 /Users/'your_user_name'/.bitnami/stackman/machines/xampp/vm/machine.qcow2 对我来说这还不够 - Xampp 失败并出现错误: 错误:启动“XAMPP”堆栈时出错:无法启动堆栈:ssh 不可访问

        5. 我的解决方案是从文件夹 xampp 中放置整个结构 /Users/'your_user_name'/.my_blocked_files_bitnami/stackman/machines/xampp 到这里: /Users/'your_user_name'/.bitnami/stackman/machines/xampp

        您可以在重命名当前文件夹之前 /Users/'your_user_name'/.bitnami/stackman/machines/xampp 类似于 /Users/'your_user_name'/.bitnami/stackman/machines/new_xampp_without_my_projects

        1. 然后启动 Xampp(Xampp 应该说明不兼容的版本,但允许继续),启动所有服务,挂载磁盘。按“Expore”,您应该会看到所有旧项目。

        谢谢。

        【讨论】:

          【解决方案4】:

          您可以在终端输入此代码

          在这段代码之前你应该关闭 xampp

          rm -rf ~/.bitnami/stackman 
          

          【讨论】:

            【解决方案5】:

            您可以通过更新 xampp ver 7.2.34 来解决这个问题。

            https://www.apachefriends.org/download.html

            【讨论】:

            • 确保备份 /Applications/XAMPP/xamppfiles/ 不想丢失 httpd-vhosts.conf
            【解决方案6】:

            我尝试在 MACos Big Sur 上重新安装 XAMPP,它成功了。但是,我的文件没有恢复。

            【讨论】:

              【解决方案7】:

              我遇到了同样的问题。这就是我解决它的方法: 首先,确保在 XAMPP VM 中备份文件。您的文件在

              /Users/'your_user_name'/.bitnami/stackman/machines/xampp/vm/machine.qcow2

              然后您可以再次重新安装 XAMPP。我已经安装了 7.4.12,它运行良好。 如果您看到堆栈错误消息,您必须这样做:

              1. 关闭 XAMPP

              2. 打开一个终端并使用以下代码删除堆栈文件夹:

                rm -rf ~/.bitnami/stackman

              3. 打开 XAMPP 并检查是否创建了新的 stackman 文件夹。

              /Users/'your_user_name'/.bitnami/stackman/

              1. 如果没有,则启动 XAPP 并再次停止。创建 stackman 文件夹后,用您的备份文件覆盖下面的文件。

              /Users/'your_user_name'/.bitnami/stackman/machines/xampp/vm/machine.qcow2

              1. 再次关闭 XAMPP 并重新启动。

              瞧!这是你的文件...

              【讨论】:

              • 感谢工作正常。但是VM用新的IP更改了我的旧IP。我们可以改变它吗?
              【解决方案8】:

              安装 Big Sur 后,如果 XAMPP 未打开,请从其网站获取最新版本的 XAMPP (7.4.12)。

              如果您最终遇到错误“启动“XAMPP”堆栈时出错:无法计算 MAC 地址:信号被终止”。安装最新版本后,请执行以下操作:

              转到终端 -> cd ~/.bitnami/stackman/helpers mv hyperkit hyperkit_backup

              XAMPP 之后打开并告诉它第一次打开,但至少我找到了 Big Sur 升级之前的所有文件等。

              【讨论】:

                【解决方案9】:

                安装 XAMPP 7.4.12,在 MacOS Big Sur 中完美运行

                【讨论】:

                  【解决方案10】:

                  同样的事情发生在我身上,但版本 7.4.12 似乎工作正常。我从下面的链接下载它。我一直在阅读,问题似乎是 Big Sur 更改了一些默认设置的路径,因此应用程序无法启动。同样的事情也发生在 Apache NetBeans 上。

                  XAMPP 下载链接:

                  (https://sourceforge.net/projects/xampp/files/XAMPP%20Mac%20OS%20X/7.4.12/)

                  【讨论】:

                    猜你喜欢
                    • 2021-07-22
                    • 1970-01-01
                    • 2021-11-13
                    • 2021-07-22
                    • 2021-04-15
                    • 2021-03-15
                    • 1970-01-01
                    • 2021-08-19
                    • 1970-01-01
                    相关资源
                    最近更新 更多